HTML5 and Text input boxes

I am putting together an example of a Command line interface for possible use in some training content. The Flash output version works fine, but when I run the HTML5 version, the text input boxes seem to revert to their default state and appear with the phrase "Type your text here" already filled in.

Is there a way around this, or is this on a list to be fixed?


13 Replies
Kevin Thorn

Hey Peter,

Not sure if that's a bug rather how HTML5 handles text entry boxes as compared to a desktop Flash output.

One possible way to have a consistent message is in the TextEntry variable default value enter a message of your own. By doing this it behaves slightly different. I've not tested it in HTML5 and may have the same results but worth a try.

Pete Rix

I'm having similar issues with a course I've been building. Since the interaction requires the users to fill in a chart with multiple input fields, I chose to do the interactivity manually with input fields and variables rather than through the template interaction (which I believe only allows you to do one input per screen? If I'm wrong, a point in the correct direction would be greatly appreciated). I think there is a spot to change up the "type your text here" prompt from within the template interaction, but for the life of me can't find a setting for that outside of the template.

I'm only seeing the prompt come up when viewing the course through the HTML5 url. I've tried placing in default values of 0 and even an empty space, but it does interact differently to the default prompt (requires user to manually delete).

I see that it's been a few months since the original post. Has anyone found a workaround for this issue? Any help would be greatly appreciated. Thanks ahead of time.

Anthony LEPOT

You can change the deffault text or delete it,

After publishing, go in the "mobile" folder and edit the "storyline_compiled.js" with a text editor.

Search "type your text here" in the document with ctrl+F and replace or delete the text between the brackets but not the brackets.

save and close, et voilà.

!! you must re-do it each time you publish your project !!

Leslie McKerchie

Hi Marcel!

I can find one other reference here and the resolution was:

Bringing the Text Entry object to the front of the slide. 

To do this: click the Text Entry object in the slide to select it, click Arrange from the tools above and select "Bring to Front". Publish your course again.

If this does not help you, you may want to consider sending your .story file to our support team.