HTML5 Retry Quiz problem

Hello,

when I publish a storyline quiz to "Include html5 output", test it on an iPad from a link (not using the Articulate Mobile Player), and click the retry quiz button on the results slide, I cannot select a new answer to the questions. It jumps to the first question and the radio buttons are clear but cannot be selected. It works fine on a PC but not on the iPad. The .story file is attached. Any suggestions? Thanks.

49 Replies
Peter Anderson

Hi Joe, 

Sorry for the trouble. We're working on a known issue with retrying quizzes on the iPad when viewed in HTML5, but it would be a huge help if you were willing to share your file with us to help us get a better idea of exactly what's going on. Would you be willing to open a case with the support team? Thanks for your help!

Steve Andrews

I've also have this problem. Initially I thought there might be something wrong with the template I'd built ,but this simple test file I created has the same issue. https://dl.dropbox.com/u/841877/test/test%20output/story.html

Source file attached.

I'll submit a support request - hopefully a fix is in the pipeline.

Peter Anderson

Sorry, Ryan. Unfortunately, this is a known issue. It'll be fixed in the next software update for Storyline, which should be getting released soon. In the meantime, when a learner needs to retake a quiz in this scenario, they'll need to view the Flash version of the course in a supported browser, or view it in the Articulate Mobile Player on an iPad.

The only other option would be to remove the question bank, I believe. 

Ryan Reilly

Thanks Pete.

OK, I may try to just sequence the question slides one after another instead of using a question bank. I realize I will lose the randomization functionality but it's a necessary trade off to get the Quiz Retry functionality to work.

Do you know of anything I should watch out for going this route?

Peter Anderson

Should be pretty straightforward. I'm just sorry you'll have to shift things around a little. 

One thing you may want to do, is keep the two courses separate. One with the question bank. One with individual quiz slides. 

That way, when the new update drops, you'll still have the question bank course intact and you can simply republish that one with the update installed and it should work perfectly. 

Good luck, Ryan!

Peter Anderson

Steven Andrews said:

I've also have this problem. Initially I thought there might be something wrong with the template I'd built ,but this simple test file I created has the same issue. https://dl.dropbox.com/u/841877/test/test%20output/story.html

Source file attached.

I'll submit a support request - hopefully a fix is in the pipeline.


Hey Steve, 

As you know, your original issue has been sent to our QA team for a future fix. I wanted to share the workaround here with anyone else who may bump into a similar problem:

If a user simply wants to be able to change their answer, set unlimited attempts to the question then add a trigger to the 'Try Again' button to jump to the same slide (to loop them back to question again) until they answer correctly.

We'll try to get this fixed in a future update. 

Thanks for your patience, Steve

Ashley Terwilliger

Hi Zio,

This thread is a bit older, but in a similar situation here, I just checked again on Juanjo's case and it seems that we were able to replicate it after the fourth retry attempt and it was reported to our QA team. The one workaround suggested was to manually create a retry quiz button and use "Reset results" trigger to be able to take the quiz again. If you'd like us to test your .story file as well, please feel free to share it here. 

In regards to your "submit" button not displaying, have you checked the individual slide properties to see if it was disabled? 

Sherri Sagers

I'm having a similar issue with modules that I convert from Storyline 1 to Storyline 2. The quiz questions work fine on the initial pass, but when I retry the quiz, the first question won't let me select an answer until I first click on the seekbar. After I do that, I can then answer the question and continue on. 

Any known fixes for this?

Ashley Terwilliger

Hi Sherri,

This thread is a bit older and as suc only dealt with Storyline 1. Are you able to confirm that you're working on local project files as described here. You'll also want to make sure that you're testing the content within the intended publish environment as detailed here. 

If you're still seeing the behave after checking into those could you share a sample .story file with us here? 

Sherri Sagers

Thanks for your reply. Yes, I see the problem when I preview from the file on my hard drive and I also see it when I publish and place on our LMS. This was originally a Storyline 1 file that was converted to a Storyline 2 file. We never saw the problem in the Storyline 1 version. I'll attach a copy of the file that I edited to be a little shorter. I previewed this test file and saw the same issue. If you retry the quiz, you can't select an answer on Q1 until after you click the seekbar. From then on, everything seems fine.

Thanks for any help!