huge file when publishing to CD

I have just published a project to CD using Storyline 2 and it creates a huge file (1.14 GB) so of course I can't publish it on the flash drive I have for it.  The previous edition of the same project published in Storyline 1 was 320 MB--no new videos or large files.

I also seem to be having a previous problem with SL2 in that the video settings won't always let me change the compression setting--I thought that had been fixed!?

I really don't want to go back and use SL1 again.  Any ideas?

14 Replies
Christie Pollick

Hi, Frances -- Thanks for reaching out with your question! Regarding video setting, please see this thread for additional information on where you would make those changes. 

And would it be possible for you to share your SL1 file with me so that I am able to do some testing on my machine and see if I encounter the same behavior when publishing it in SL2? 

Frances Steinberg

Hi, Christie.  I have spent a "lifetime" corresponding with your tech team about the video setting issue--I know quite a bit about video conversion and can never create settings for mp4 that SL2 likes unless I use Replay to produce the file.  Seriously, you need to drop this feature and go back to the way it was in SL1 because it's incredibly frustrating to the majority of SL2 users.

As to my file--I doubt you want the story files but need the folder?

Christie Pollick

Hi, Frances -- My apologies for your frustration, and if you would like to share your thoughts regarding any features or suggestions you have for improvement, you are always welcome to share with our Product Development team using this form

As actually, I would appreciate it if you could share your .story or source file from SL1 so that I can upgrade it to SL2 on my machine and publish to see if I also experience a huge jump in total file size. I will be happy to take a look at it first thing in the morning, or if you need a more immediate response, you are welcome to share the file with our Support Engineers who can weigh in with their observations. :)

Frances Steinberg

Have had sooooo many conversations with the tech team (who spoke to the Product Development team themselves) about this and submitted it as a ticket--as nothing has changed since SL2 has come out it seems that Articulate prefers to make the few people who like to be able to alter the compression of the file happy, even though it frustrates the bulk of us!!! Love Articulate, but this issue has definitely driven me crazy a bit--not good when the new version of a product is less user friendly than the older one ;-)

I can't seem to add the file here as an attachment--it just blanks me from the page and says the page can't be found.  But when I upgraded it to SL2 from SL1 myself there was no change in file size--the file is not the issue, it's the media components of the folder when published that cause the increase in size.

Sorry if I'm sounding a bit grumpy, just very busy right now and I don't have time to republish all the videos or rework it in SL. Cheers, Frances

Ashley Terwilliger

Hi Frances,

Christie passed along this thread to me, as I know it was something we've discussed before and that you also talked about with Justin Grenier. I see you're also currently working on this issue with Renato(Case # 00727834 for my reference), so I went ahead and escalated it to one of our Senior Support Engineers so that they can continue to discuss with you as some of the previous issues you discussed did get reported to our QA team, so I just want to ensure we're not duplicating efforts here (yours or ours). I'll follow along in that case as well so that we can share any additional information here in the forums and you'll be hearing from someone soon. 

Please feel free to let me know if you need anything else. 

Frances Steinberg

Hi, Ashley.  Thanks for getting involved.  I have communicated with Emily but, as we say in NZ, haven't had any joy just yet.  The original issue of the progressive uploading has been resolved, but the current problem is that SL2 publishes much, much, much bigger files than does SL1 using identical material.  Given that we have boxes of designed flash drive cards on which we put the material, this creates a huge headache because we can't fit the SL2 material onto the drive.

I sooooooo don't want to have to go back and reproduce this huge project in SL1 just so it fits.  Hopefully, there's an answer.  Cheers, Frances

Frances Steinberg

Hello, again Ashley.  I've done some further testing and it doesn't seem it's a video issue at all.  SL2 publishes identical material in much larger files no matter what it is.  Even just a line of text publishes in SL1 as .98 MB while SL2 is 1.32.  Can you try to see if it happens the same way for you?

Ashley Terwilliger

Thanks Frances for reaching back out here - and I'm keeping an eye on your case with Emily as well. I am certainly not a programmer or developer, but know that SL2 and SL1 are different products as a whole, and even simple things like text were improved, for example changes to ligature support. I don't know that I would expect them to publish the same file size and output and can see how that may be problematic if you had relied on a particular file size/structure and built courses to match that. 

I'm going to touch base with Emily to see what other testing is going on and what can be shared with our QA team for further investigation - they're the ones I'd defer to for expertise on the issues, so we'll want to get it into their hands. 

Frances Steinberg

Well, apart from a "that's the way it is" reply, it doesn't look like there are any fixes.  My final communication with Emily said she is sending this to the QA team, but I really think that purchasers and users should be made aware of this difference between the products, because if I had known, I wouldn't have spent considerable hours on an SL2 project when it is of no use to me.  I can find no mention of this in the specs.

What's more, now that I've updated and produced the project in SL2, even though it says it created a backup file in SL1, I can no longer get the previous project to open in SL1 so I'm going to have to spend at least a week re-creating it there.

As you know I've always been a big supporter of Articulate, but right now I'm a very unhappy and frustrated user. :-(

Steve Gannon

Frances,

Regarding your SL1 backup file, when Storyline 2 is installed on a machine with Storyline 1 already installed, Storyline 2 will launch if you double-click a file with the .story extension. If you haven't already done so, try opening Storyline 1 via the Storyline 1 desktop icon or Windows Start Menu and then open the backup file.

Ashley Terwilliger

Hi Frances, 

First off, Steve is entirely spot on in regards to opening the file and it will always default to opening in your latest install (likely SL2). What I tend to do is use the "open with" and then choose Storyline 1 or if you open Storyline 1 and then browse for the file that should also allow you to open it that way. 

I did chat with Emily earlier, and she did share the information in regards to compression and what we've shared with our QA team. I don't envision that changing but, we have passed along the messages here and as a part of your case so that they're aware of the challenges faced by our customers. Additionally in regards to the file size, a number of things were improved in terms of overall quality for publishing with SL2 and new features - so that is going to account for the change in the file size. Again, I know that's not the answer you're looking for and doesn't include a resolution, but I did want to share here for clarity and confirmation. As to the language used in the specs that may have given you pause in upgrading, I'll also be sure to share that with our team as it'll be something to keep in mind as they refine the current set up and look towards the future. 

If there is anything else that myself or Emily can do to assist, please feel free to let us know. 

Frances Steinberg

Hello, Ashley and Steve.  No, it won't open in SL1--when I browse for that file when I'm in SL1, it just gives me the error message attached, even though I originally created it in SL1.  And it won't allow me to "open with", it gives me the same error message.

And as to the quality of the published outcome, the videos set at optimum quality in SL1 still produce a file a third the size of the regular publishing in SL2.

I apologise for being grumpy--am a tiny bit less so since I found a copy of the 2nd edition SL1 version in a flash drive so I can use that to make the changes and it will only take me a morning rather than a week ;-)

I love SL2, but I really think this issue should be made clear so that people don't struggle like I have.  Cheers, Frances

Ashley Terwilliger

Hi Frances, 

When seeing that error message - you mentioned SL1 Update 2, could the file you're trying to open also have been worked on in any of the more recent Updates of SL1? That could be leading to the same type of error message if an element of corruption snuck in or you're using updates that included fixes/features that didn't work in SL1 Update 2...it's even before my time, so I don't know for certain how it would have behaved. 

As for the published quality (videos and changing it as a whole in the publish window) that is something we've shared with our team, but we've upped it as a whole in Storyline 2 so it's to be expected (although in your case not desired). We did talk about this with our QA team today - and I know Emily shared that update with you as well.