Hyperlinks don't work :-(

Hi everyone!

I saw a lot of discussion about hyperlinks problems but I didn't see an available solution for me...

Well, I simply created a text box and then insert a hyperlink, so I have:

But nothing happens... My cursor doesn't even change state!

Is this because there are several hyperlinks in the same screen?

Need your help please.....

PS : my storyline file is in attached.

15 Replies
Nancy Woinoski

Hi Claire, there are 2 things you need to change when setting up your text hyperlinks.

1. don't but the around the http address

2. Before inserting the trigger select the text in the text box  (don't just add the trigger to the text box itself.

Hope this makes sense. I modified the first two links in your story to show you they work (note they will not work in preview mode)

Claire GAILLARD

Dear Nancy,

Thank you for your so quick answer! But I'm not sure to understand (I think that words are missing in the point 1 of your message?).

I tried to re-do my hyperlinks, following your instructions:

- if I select the text and then insert the link, the link is specifically on the text and not on the text box --> doesn't work.

- if I select the text box and then insert the link (as Helen suggested too): OK, it works, but I lose the formatting of the text (Storyline doesn't consider it as a hyperlink)

Do you see what I mean?

Is there any solution or may I format the hyperlink texts myself (underline+blue for example)?

Phoebe Lu

Hello All,

I had the same problem recently.

Same here, I tried  this "select the text box and then insert the link", it works while "select the text itself", it doesn't work!

More, I tried to insert a WORD/PDF file (not a http link), using the way "select the text box and then upload the WORD/PDF file" and "select the text itself", it did NOT work at all !!!! Frustrating!

Does anyone know how to get it work --- insert a WORD/PDF file using "Jump to URL/File"?

Thanks a lot

Claire GAILLARD

How strange?!! I did exactly the same method (select the text and then insert the link) in the file in attached and it works!!

But I'm unable to understand why....

What ever, thank you a lot everyone for your help! I knew the trick of using hotspot or "imitating" a hypertext style

Sometimes, Storyline makes us clever!

Phoebe Lu

Woooooow, I finally figured it out.

Seems storyline right now does NOT support any WORD file by using "Jump to URL/File" trigger.

Except WORD file, the PDF, JPEG and other Http format all work very well under this trigger.

That was my problem root, coz all I linked were WORD files before!

So, I converted all WORD file into PDF version and it worked very well!!

Hahahahaha

Ashley Terwilliger

Hi Phoebe,

You should be able to link to a word document, so I'd need to know a bit more about the steps you took to link the Word document, where it's located and then how you tested the published output. Also, if you'd like to share the Storyline file here that may help us as well - granted, if you're happy using the PDFs that obviously is working well! 

shay zinger

hey,

i just had the same problem, found 2 solutions-

1. when publishing without html5 compatibility the links wont work in chrome but will work in IE  (i know!!!) so publish with html5 and use the  - "story_html5.html" file.

2. the root to the file was too long and so the address got all mixed up and eventually trying to open a file called "folder_name.doc"

instead i placed the file in "c:" - so the root was simply "c:\file_name.doc" - works like magic!

hope it will be halpfull

Ashley Terwilliger

Thanks Shay for sharing here, and we do always recommend linking to local project files with short file names and paths that adhere to the conventions here.  

In regards to using IE, I just wanted to offer a reminder that we don't support HTML5 output in IE - and you can see the supported browsers here.