12 Replies
Teresa Donnelly

I did get it resolved, and while the course worked fine when loaded onto the SCORM Cloud, it was not an LMS issue.  The fix was with the Storyline published course, specifically the Configuration file in the LMS folder of the zipped course.  This article was linked to me by support, and this did the trick.  

http://www.articulate.com/support/storyline-2/score-doesnt-update-when-retaking-a-course 

I did load the course onto the SCORM cloud, and it worked fine without the fix, but apparently if you're using a different LMS, you have to do this step first.  This should be something that is clearly known to all Storyline users as most don't use the SCORM Cloud for their LMS.

I talked to a LOT of Instructional Designers at the recent ATD Conference & Expo in Orlando, and most do use Storyline.  It is, in my opinion, the best authoring software.  I just wish that when there's an issue between it and different LMSs, a solution would be communicated without so much back-and-forth.  :)

Many thanks!

Leslie McKerchie

Thanks for the update Teresa and for sharing the article with the community.

As you can see in that article, it's normally something that can be updated in the LMS and that solution is for user preference, and perhaps need, if it cannot be done in the LMS. It would never be our first recommendation as we do not support the modification of published output.

Glad you were able to get this sorted though and I was at ATD in Orlando and got to meet many of our users :) I'm glad you are liking the software.

Teresa Donnelly

I got a blank page too when clicking on it from here, so I copied what the page says:

Score Doesn't Update when Retaking a Course
Most learning management systems (LMSs) consider a course to be in review mode when attempting it again after the completion requirement has been met. When in review mode, new data is not reported to the LMS. This prevents learners from accidentally changing their course status from complete back to incomplete.

If you'd like to change this default behavior, it's best to change it in the LMS. However, if you'd prefer to modify the published Articulate output instead, do the following:

  1. After publishing your course, navigate to the published output, and open the LMS folder.
  2. Right-click the Configuration.js file, and select Properties.
  3. When the Properties dialog opens, uncheck Read-only (if it's selected), and click OK.
  4. Then open the Configuration.js file in a text editor, such as Notepad.
  5. Locate the following text:var REVIEW_MODE_IS_READ_ONLY = true;
  6. Change it to:var REVIEW_MODE_IS_READ_ONLY = false;
  7. Save and close the Configuration.js file.
  8. Zip the modified output, and upload it to your LMS again.

As Leslie says, this should be a last resort, as they don't support modified content.  Sure wish I could find the fix so I wouldn't have to modify it.  :)