Images in Storyline disappear from presentation after publish

 Hello,
I'm having an issue with a presentation in Storyline whereby my images (jpegs & pngs) have disappeared. They appear in the preview pane, but in the slide view, they are missing. If I then preview the project, they don't appear.

The slides these images appear on only have 1 layer. It seems as though the images are there- if you click on the slide, there is an active object outline where they should be. I have tried removing these blank boxes and re-inserting the images using the Insert> Picture function but all that is inserted is an empty object box.

I have also attempted to view the presentation on a colleague's pc with Storyline installed but the same issue has occurred.

I am working with the images locally, When creating, editing, or publishing a Storyline project, from local hard drive (typically your C: drive).


I used images from Insert> Characters > photograph>


I have put in a lot of effort and time in animating the slides and If I have to redo it again I will be behind schedule.


Please find the attached source file for your reference.

140 Replies
Christine Hendrickson

Hi Venkat,

Thanks for the file! Unfortunately, though, I'm not seeing the exact same thing. I'm not able to see any images in the course. I can see some text and a caption, but even in Story view, I see no images or characters. I see no images when previewing, either, but to be honest I expected that. 

If you re-insert an image into the course again, does it remove itself again? 

Can you try inserting the slides into a new Storyline file and add the images? If so, does the same thing happen?

Thanks!

Christine Hendrickson

Hi Venkat!

That's good news! It's difficult to say what caused it. It's possible that the images or the course may have become corrupted at some point. Just to be safe, if you haven't already, you may want to insert the slides with the images into a new course file. I wouldn't want to see you lose the images again and the work you've put into replacing them.

Thanks!

Law Blank

This same situation just happened to me.  Unfortunately, it was a 380MB file with video, flash interactions, graphics, audio and over 600 triggers....all media was wiped out after I published the file, saved it, and discovered upon my return to the file just now that it is at 15MB.  I just lost about 4 hours of work put into this version, will have to revert back to a previous version.  All the new triggers and any page assets cannot be used by copying the slide from one file to a new one...it just hangs up the new presentation.

I had just installed the Storyline Update 2 and things were working just fine.  This could be a potentially serious issue...frankly, I am afraid to open my previous version for fear of the same thing happening. 

If your staff has any ideas of the root cause, please let us know.

Christine Hendrickson

Hi Law,

I'm not sure if you're already doing this, of if you've already seen this information elsewhere. The first thing I would do is make sure that you're working with project files on your local hard drive. This goes for the Storyline project files, as well as the images and other media you add into the course. 

1.  Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 

2. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

3.  Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

Also, I've seen a few cases of this where some of the content was copied and pasted into the original course. This can cause some issues, so try to make sure you're inserting the images and movies, etc., when adding them to a new file. 

I'm very sorry to hear that you lost so much time and work with this. Hopefully you won't run into this again. If you do, please let us know so we can try to narrow down the cause and hopefully resolve this for you.

Thanks!

Michael Fimian

Hi Christine,

Glad to see this thread sent by a colleague who's working on a project with me... We found the same thing happening in a couple of projects we're working on.  Images come and go;  replacing them seems to work for the moment, then tend to disappear.  Not without a trace, however.  As mentioned by Venkat and Law, I'd never seen this happen before the release of the last update, even in SL files larger than a GB.  And, like Venkat, there appears to be a trace left behind on the slide itself, but the actual object is gone from the timeline.

When adding a replacement image, a postage-sized stamp outline (kike and ampty text field is created and draggable, but not re-sizable, and has no image on the screen...

I'll try creating a new empty file, import the original file into that, and see if the issue persists and is replicable...

Michael

Michael Fimian

Hi Christine,

Just tried an import of the course into a new shell, and the behavior persisted w respect to graphics...  At least the ones that were in there prior to doing a Save as...

Created another shell, then imported the original file into it, and the lead slides; graphics disappeared.

However, when I add other graphics to the file, they seem to take OK...

Strange!

Christine Hendrickson

Hi Michael,

Thanks for the info and the screenshot! Where are the course files and image files being stored? Try to make sure they're on your local hard drive, if possible. 

Also, are there any special characters in the image file names (underscores, dashes, spaces, etc.)? If so, try renaming the image files and see if re-inserting them makes a difference.

If you've checked all of that out, are you able to share one of the files (either the original or one of the new files)? Looks like something our support team may want to check out.

Hopefully we'll be able to get this figured out soon!

Thanks

Christine

Doug Brown

Hi Michael

Just monitoring this chat and thought I might make an off topic comment.

The effect you're describing sounds very similar to an issue that I had with other products (MDM Multidmedia, Authorware etc)

It turned out that the temporary cache area used during development was getting corrupted on larger files.

The workaround was to resave as another name before closing the file.

This created a new temp cache without the legacy corrupted files.

Renaming the graphics would also remove any reference to the corrupted graphic.

It maybe a similar issue happening with storyline, so resaving to a new name may be advisable

Sorry for the rant, but it may help

Doug

Michael Fimian

Thanks Doug, and Vanket...

Good to know;  I always do a Save as... and increase the version number one I open the file;  but from now on I'l do so before I close the file, then got to the next in line once I start up again...  I remember during the beta period, one of my files versioned to FileName_79!

M

Julie Daniels

Same issue here...with one of the files from Michael Fimian's projects also. In fact, I opened the file and copied and pasted one line of text in, and all my graphics disappeared only in that scene. I closed the file (without saving any changes) and reopened it, and the graphics were back. I realized that as soon as I click on a slide within the scene, all the graphics disappear (and the text formats itself differently). In fact, even if I click on a slide from Story View, the images disappear. I made a screen recording and uploaded to tech support.

Julie

Kathy Hartman

Same issue here. I lost over 50 images. Fortunately I had saved the project and was able to build a new presentation.  I reinstalled SL and cleaned up my computer...but SL still stops working. 

Does copying and pasting within the same project also cause problems?  How about buttons?  I have been copying buttons to multiple layers.

Christine Hendrickson

Good morning!

@Julie: 

I was able to find your case this morning (#00328660 for my reference). I see that Gren is working with you on this case. Looks like she sent out a response this morning with some troubleshooting steps and suggestions. Have you had a chance to try the steps she sent? If so, and the problem is still happening, please try responding to her so she can get a little more information on the issue. If you haven't received the email, please try checking your spam folder. If you still can't find the message, just let me know and I'll try sending it out to you again.

@Kathy:

Welcome to the community! Just to clarify, are you copying and pasting content from within the course, or from an external source? If you copy images from outside of the course and paste it into your project, they may not save correctly. Having said that, however, the images and buttons should display and save correctly if you're simply copying from within your project. Can you tell me if you experience this with any Storyline course you create, or if this seems to happen in a specific file? If you haven't already, try creating a new blank Storyline course and then copy and paste some content throughout the course. Does the same thing happen?

Hopefully we'll be able to narrow this down and get it resolved for you. If you discover any new information regarding this issue, or if you make any progress in your support case (Julie), please let me know.

Thanks!

Julie Daniels

Updates 


When I create a new file, everything is fine.

When I create a new file and import from the broken file, no images import.

I tried to preview one of the scenes (4), and I can't seem to navigate to the second slide in the scene.

I got instructions to uninstall, clean up and reinstall, which I will try, but since the file is doing this on multiple computers, but no other files are doing it, it makes me think it's more likely something with the file than something with the install, but I'll try it anyway...

Julie

Christine Hendrickson

Good morning Julie!

Thanks very much for the update, I appreciate it. I just checked the case and it looks like the problem still exists after taking those steps.

None of the machines are able to work with this file, correct? Are all of the machines using the same operating system, or do they vary? I'm curious about this, since you've stated that it started after the last update. Has any installation on any of the machines not been updated with Update 2? Might sound silly, but it couldn't hurt to install a trial version on one of the machines and see if the file works there. If it does, then maybe our support team can confirm it's an issue with the update and assist with rolling back the version you're currently using. 

Thanks again for keeping me updated, Julie.

I hope you have a great day,

Christine

Michael Culligan

I am working with on five course titles due for release in May and have just discovered a similar issue in one of the courses.  While most images are appearing correctly, there are several images that have disappeared from slides that were imported to the course from other StoryLine courses. 

I am just starting to explore the issue, but wanted to acknowledge that this is an issue on our part as well.