Imported Engage files will not load/run when published.

The problem I am having is that imported Engage files will not load/run when the Storyline file is published.

Thinking that it could be the template I am using I have attempted to create 2 new files with engage imports.

1 with the template and the other a Blank File with only 2 slides a title slide and the imported Engage file.

Neither of them load when the file is published (web). I am including a file with a screen shot of my publishing settings. Do I need to have the Engage files in a specific directory path to be able to import them correctly? Do I need to publish the file to a specific directory? This problem has been occurring for nearly a week. I have broken a number of deadlines now because I cannot find a way to fix this issue. I have sent this request to support twice, now I hope the community can assist.

19 Replies
Christine Hendrickson

Hi David,

You don't need to have the interaction in a specific directory to import, but you do need to make sure the directory is local. In other words, make sure that you're not importing from a network, USB drive, etc. 

What method are you using to import the Engage interaction? You might want to take a look at this tutorial, if you haven't already, just to make sure you're not missing any steps. 

I'm sorry the issue wasn't resolved in your previous cases. Do you still have the case numbers, so I can take a look at them?

Also, are you able to share the course with the community? If you can attach your .story file to this thread, maybe we can find the issue.

Thanks!

David Quackenbush

Hello Christine,

Thank you for the suggestions. I have used all 3 options in the tutorials with the same results. 

One of the previous case numbers is 00305807, Sid was working on it for me. His suggestions for resolution were unsuccessful.

I have been attempting to upload the files I mentioned for a new support case and to the forums, but keep getting errors. 

I will continue to try though. My big concern is that New Blank file that has the same problem. This makes me feel its may be a issue with Storyline or Engage and not the files. Could that be the case?

Christine Hendrickson

Good morning David,

Thanks for getting back to me. I apologize for the difficulty you had getting a new case opened. From what I understand there was a bit of downtime for the case system, due to some maintenance. This would also explain why I wasn't able to see your previous cases.

I was able to take a look this morning and I found the case you mentioned (thank you for the number!). It looks like this case is still open, however, so Sid or another member of the tech team should be in touch with you soon. 

In the mean time, can you try posting the .story file here again? You may want to try with the blank file, if the other file is too large it may time out. 

Thanks again, David!

David Quackenbush

Thanks Danny - I did the same thing the first time and have switched to importing the intr files directly.

I can see the intrs in Storyline and even preview and edit them via Storyline. The problem is when I publish.

The interactions don't load - you know how you usually get the spinning circle then the intr starts, well that doesn't happen.

Its just a blank slide.

I've reviewed the tips in the forums and its now happening on 3 different files. I'm reluctant to open any other Storyline files now, incase it happens to them as well.

Christine Hendrickson

Hi David,

Thanks for uploading the file

I published the file to Articulate Online, temporarily, for testing. I'll take it down as soon as we're finished.

I did not use HTML5 when publishing. 

Take a look at the published version:

http://chendrickson.articulate-online.com/4556530699

With this published version, I'm able to see the Engage Interaction.

Now, when you're publishing for the web, how are you viewing the content? Are you running it locally? That may be the issue. We recommend you test the content in the environment you have published for, such as on a web server via a valid HTTP address, an LMS, or Articulate Online. You can publish a presentation for CD and view the content locally and most web objects will display properly. However, if you don't intend on distributing your content via CD, we strongly encourage you to test your content where you intend to host it.

David Quackenbush

Christine,

I am publishing for Web and putting the output on a public Dropbox.com directory.

Can you provide me with browser settings for Goodle Chrome, in case that is the issue?

Also if you like I can give you the link to the Dropbox directory to check.

But I can't post that link publicly can I email it to you?

Christine Hendrickson

Hi David,

I've been looking around and I did find another post of yours about this here. It's good to know that the content will be published on an LMS in the future, because I'm not sure how this will work out on Dropbox. I saw that you mentioned that you were trying to get an option for testing with your LMS, that really would be the best thing for you to do. 

As I mentioned earlier, the interaction is functioning on Articulate Online, but I'm not able to completely test the content in Dropbox. I can look at the link that you're using (you are welcome to send it to me in a private message, if you'd like).

I do have a couple of suggestions, though. Until you're able to actually test on your LMS, you could always use Articulate Online to test. There's a 30 day free trial for the service. This will allow you to publish and test your content online (Dropbox is really meant for storage, so while it's a nice free service to have it may not be the best for displaying and testing this content, especially since you'll be publishing to an LMS after you've completed the courses). If, after the 30 day trial, you're unable to get access to a test section of your current LMS, you could always search for a free LMS or ask other community members for some suggestions. I'm sure there are some out there that may work for you. Keep in mind they may be limited, however, since they're free, but it may work well enough for you to test your content before publishing to your current LMS.

Sharon Maguire

Hi all, I had the same problem... go to http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html in the browser that you use to view the Storyline output and change the global security settings to 'always allow'.  Note, that the picture you will see on your screen in your browser is the settings manager itself... not an actual image... so you make the required security change directly within what appears to be an image in your browser.

regards

Sharon

Afua Gyasi

Thanks for this suggessions Sharon. I have the same problem too and your sugession worked perfectly on my computer. i.e I was able to view the engage interactions that aai inserted as web objects. My question though is "what happens to the end users of this course? Do I have to put intructions for them to do this before the course begins?" I  say this because I tested the same published file that worked fine after i did what you suggested on a co-worker's computer and i got the same problem.

Do you or anyone else know what i can do?

Sharon Maguire

Hi Afua,

Hmmm, it might be a good idea to have a FAQ's section and add the solution to it.  I'm considering adding it to our FAQ's.  Or, perhaps even make it part of the System Specifications that lists what is required by end users for optimal course experience.  Sorry I can't help more.

regards

Sharon