Insert video from Amazon S3

My workplace recently had to take over third party story files that were embedded with videos. The files sizes range 3-5 gig and take forever to save and publish, and we can't even store them without getting transmission errors.

I've been looking into using video embed codes. I extracted the videos and stored them in Amazon S3. I went by this tutorial to generate the embed code and got this:

<object classid=”clsid:D27CDB6E-AE6D-11cf-96B8-444553540000″ codebase=”http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0″ width=”1850” height=”1040” title=”Module_1_Introduction”>
<param name=”movie” value=”https://s3.amazonaws.com/aicpa-isd-001/Articulate/data-analytics/S01_M01/video_6FuG2CgeJ9R_22_48_1850x1040.mp4” />
<param name=”quality” value=”high” />
<embed src=”https://s3.amazonaws.com/aicpa-isd-001/Articulate/data-analytics/S01_M01/video_6FuG2CgeJ9R_22_48_1850x1040.mp4” quality=”high” pluginspage=”http://www.macromedia.com/go/getflashplayer” type=”application/x-shockwave-flash” width=”1850” height=”1040“></embed>
</object>

But when I copy and paste the code into the Insert Video from Website box, I get the result captured in the 1st attachment. SL inserted extra quote marks into the embed code. 

I tried stripping the quote marks out of the code before pasting. It set up the video frame, but the 2nd attachment, which is the preview, shows that the video is unavailable. How do I fix this?

 

8 Replies
Michael Hinze

The code you listed above is HTML used to embed a video into a webpage. To embed a video into Storyline, your code should look something like this:

<iframe width="560" height="315" src="https://s3.amazonaws.com/aicpa-isd-001/Articulate/data-analytics/S01_M01/video_6FuG2CgeJ9R_22_48_1850x1040.mp4" frameborder="0" allowfullscreen=""></iframe>

I tried that code and your video is displayed as expected. You could also use a Storyline webobject and link it to your video's URL. In order to view embedded vids or web objects , you do need to PUBLISH your project.

R. Eric Smith

Hello, back again. The Digital Delivery Services guy told me not to use Amazon S3 because it's not set up for global streaming. He said to use the media server. I uploaded the videos to it via FileZilla, but they're not always displaying correctly. Sometimes I get a 404 error, sometimes I get a miniature player in the middle of the screen, and sometimes it works after reloading.

I inserted this as a web object:

https://media.aicpa.org/Association/Data%20Analytics/S01_M01/video_6FuG2CgeJ9R_22_48_1850x1040.mp4

Same thing happens when I try the iframe tags.

Michael Hinze

Correct, AWS S3 provides mass storage for files (inc. videos), but it's not a streaming media server. The issue seems to be with the video itself or the server. I get the same inconsistent playback and errors, even if I try your video URL directly in a browser. I tried in various browsers and devices.

R. Eric Smith

OK, the DDS guy sent me an html file to use as a template. I put the video path in it. Instead of using the insert video feature, I have a blank slide that has a Jump to URL trigger to the html. It was opening the video in a new window, so I changed the browser option to display in current browser window. Problem is, the video is created in a new instance that overwrites the SL player features (like the prev & next buttons). I can use the back button on the browser to return to the course, but it goes back to the first slide. Is there a way to keep the SL player visible when the video loads?