13 Replies
Peter Anderson

Welcome to the community, Tony!

There are two ways to add a YouTube video to Storyline:

   *  Insert > Video > Video from Website

   *  Insert > Web Object

Each method has its unique benefits. 

The freezing seems unusual though. The trial software is identical to the purchased version, so that shouldn't be an issue. Here are a few tips to avoid strange behavior:

1.  Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 

2. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

3.  Avoid using special characters, accents or symbols in your file names.

Tony Spitzer

Hi Peter,

Thanks for that, I copied the project to my C Drive and tried all the steps above including adding the old embed code and it still freezes. I have also tried inserting a web object following the tips on the tutorial - e.g. www.youtube.com/embed/'video id' and that wont seem to play either even thought when i test the link it works. - getting frustrated.....

April  Bonner

I am having a problem playing a YouTube video --only upon publishing; it works fine in Preview. I am having the video play from a Learner initiated trigger, so I am using the " Insert > Video > Video from Website" method. I am working on my 'C' drive, my path is only 38 characters and has no funky symbols.

I unselected the 'Publishing for HTML5 and Mobile Devices' options.

Any other suggestions?

david mckisick

Hello April! I have noticed problems with this as well when working behind a complex Firewall. Maybe check your browsers security settings and your companies security policies for playing YouTube videos behind a company firewall, if you are indeed doing that. Also, please double check to ensure the link you embedded is correct. I didn't think you could play embedded video's in Preview mode. When I have tried that I always got a popup message saying that you could not do that in Preview mode, so I always had to create a small test file and then publish that to make sure my video's played correctly.

April  Bonner

Thanks for responding David-- but I don't think it's a firewall issue (although I am trying to verify that) --as you can see by the attached files, it plays readily in the Preview (very bottom image), so I believe I have embedded it correctly. But it's like the movie video is just gone from the published version (directly below).

Ashley Terwilliger-Pollard

Hi April and welcome to Heroes! 

Have you tested your published content off your local drive or from the intended environment? Testing it locally could cause you to encounter security restrictions which may cause the video (or other elements of your course to fail). 

If you're still having difficulty, can you share the .story file here with us or a link to the Youtube video so we can test it as well? 

April  Bonner

Hello Ashley:

I did move it to our Web Server and test it from there---same results. I have attached the story file. Your help is much appreciated.

Also, I just noticed the hyperlinks are not working either; they are to external websites. (In the version I sent you one is broken--the FAR one--so ignore that one.) I followed tutorials and checked forums, but see no reason for not working.

Ashley Terwilliger-Pollard

Hi April,

Thanks for sharing your file with us here. I tested the course and published it to my Articulate online account and the video played successfully, and I tested a hyperlink on slide 1.5 and that worked as expected as well. You can view my test publish here: http://aterwilliger.articulate-online.com/9369910821

Also, you'll want to check that you're Flash version is updated within the browser you're using to view the course, and use one of the recommended browsers here.  (I tested it in Chrome). 

Also did you check into the firewall issue as David mentioned? 

April  Bonner

Thank-you, Ashley

I have all of the system requirements, including up to date flash player.

A couple of questions:

1.) I noticed that where you published it the FONTS were huge in places; why is that?

2.) I am having a hard time finding someone who can tell me if our security settings might be impacting the launching of the video or links. Can you give me any specific settings that could cause the conflict? That might illicit a more helpful response from IT.

Ashley Terwilliger-Pollard

Hi April,

That's how the fonts looked when I opened it - I wasn't sure if it was by design to I left it as is. Just because of the difference between what you see and what I received, you'll also want to check the following:

Did the items work for you in the version I published? What browser(s) did you test it in? Did you check that within the browser itself Flash player was updated (one great way to check is to open a site like supportdetails.com). Other security settings may be browser or company specific, so it's hard to know - but if you're able to get to those sites, I'd see if there is a pop up blocker within your browser, if there is a company firewall, etc. 

April  Bonner

This is odd, I went back to my file location on our web server (to double check the number of characters in the path--although I had checked it yesterday.) anyway, I did not change anything---but when I launched it this time, the links and video worked. I am VERY perplexed.

I had others test as well, it seems to be working.

Alls well that ends well, but I am scared to make edits and republish....