iPad Articulate Mobile Player unable to connect

So I know this was an issue a while ago but here is what is going on now that I am not sure of.  We have a group of Tin Can courses that our client has been accessing through their iPad airs with no issues.  It launches through our lms into the app just fine, tracks and does everything it is supposed to.  The client has brought on a few new employees with new iPad airs and two of these users are getting the "Unable to Connect to the Server" error.  It is not a connection to the internet issue because they have to be connected to the internet otherwise they would not have been able to launch the course in the first place.  

There is nothing wrong with the user credentials because we can take the same username and access it on a different iPad and have no error.  So it is something particular to these two iPads that is causing the error and not letting the iPad pass the information back to the lms.  

Does anyone have any idea of a setting or something on these iPads that might be causing it?  I am at a loss.  Thanks.

17 Replies
Ashley Terwilliger

Hi Randy,

What iOS are they using? Did anything changes in terms of what mobile player they're accessing it through? 

I haven't heard of specific devices just not being able to connect either - so I hope that if someone in the community has run across this they're able to share the information here as well. 

Ashley Terwilliger

Hi Randy,

Is it safe to assume everyone (even the older iPads) are also using the iOS 8 and the newest version of the mobile player? I've been testing a few courses recently with the same set up (iPad mini though) and haven't run into that issue. If the other users are on an earlier version of either - could you share a link to the course or a copy of the .story file so that we could give it a test as well in iOS 8? It may also be worth seeing if these same users can access the course if you publish to SCORM Cloud to help confirm it's not something with the LMS, iOS8, etc. 

Randy Hill

So here is where we are at.  I just updated the iPad air I have, one they gave me to test on, to iOS 8 as well as the newest version of the Articulate app.  Where the error wasn't there before on mine, it is there now.  So something in the newest versions of iOS and the articulate app are causing issues.  The courses are tin can and we had to use the articulate app for syncing issues.  The courses had been working for the past 8 months and not until recent hires came on with this company and got new iPads with the newest versions did we see this error.  

I have our lms company looking into it as well.  The courses are private pharma courses so I can not share them unfortunately.  The courses are tin can api with both graded questions and survey questions in them.  They were originally exported from Articulate 1.  

Ashley Terwilliger

Hi Randy,

Thanks for the additional information. I just tested this myself on my iPad mini with iOS 8 (not on 8.0.2 yet) and using the mobile player version 3.16 and published a sample course for Tin Can to SCORM Cloud. I didn't see any error messages when trying to play this one. 

Here are directions on how to determine which version of the mobile player you're using and if you look at the Apple app store page you'll see the list of fixes (although I don't see anything that would indicate an issue with Tin Can). 

Can you test that link I shared and let me know if that one works for you? If it does, can you also try posting your course to SCORM Cloud which is an industry standard for testing LMS content and see how that one behaves on your iPad? 

Randy Hill

I will test the course in SCORM cloud here in a bit, I did determine that they are fine in iOS 8.0 however, I have two other ipads, one with 7.1.2 and the other with 8.02 and those give me the error.  All iPads have the Articulate mobile app 3.16 and it was when I updated to the 3.16 that I started getting the error.

Ashley Terwilliger

Sounds good Randy - and testing my link and your own course at SCORM Cloud will help us determine where the issue is in terms of the app overall or how it's communicating with your LMS. I didn't run into any problems testing that short course at SCORM Cloud using the same version of the mobile player - so we'll want to know what you find as well. 

Shahid Ismail

Hi Ashley

I am having similar sort of problems, I have my LMS as moodle and i have installed the Tin Can API plugin that Jamie Smith had provided a while ago on github.

I have an ipad with IOS 7 running and when i publish my course with Tin Can API and launch it into the App which is version 3.16 and my course seems to work perfectly fine on that and i can get completion status recorded on the LMS as well.

However the client who are based in New Zealand are launching the same course with IOS 8 on their ipad and app version 3.16 but are getting the "Unable to connect to the server" error.

I have tried SCORM CLOUD and it works fine there and also fine on moodle for me (i have tried on atleast three different ipads in the office)

Attached is the story file, can anyone help me as to why the client is getting the "Unable to connect to the server" error when launched via the app for them?

thanks

shahid

Ashley Terwilliger

Hi Randy and Shahid,

What LMS are you both using? 

You'll see that error message here described again here, and it occurs when the LMS in not able to read the data that is being sent - so I think you're best course of action is share these different results with them, especially how it behaved in SCORM Cloud, as that is an industry standard for testing content. 

I am aware of a really involved method to configure your iPad to send all of its Internet traffic through your PC, and then use Fiddler to capture that iPad traffic, described here.  It's not something we'll be able to offer support or interpretation of the data around though - but it may help your LMS team in determining what's occurring. 

Hope that helps and please feel free to keep us posted on what they figure out. 

Randy Hill

We have found the issue for us.  It has to do with the old and new versions of the articulate player.  We’ve narrowed down the exact problem between the old and new version, it’s aheader.  The old version, when setting State, would POST a form and usedthe following header:

 

Content-Type:application/json

actor=%7B%22name%22%3A%22Krista%20Rotolo%22%2C%22account%22%3A%7B%22name%22%3A%225419b719bf24885b799556b6%22%2C%22homepage%22%3A%22https%3A%2F%2Flms%2Eduratatxinsight%2Ecom%2Fapi%2Fv1%2F%22%7D%7D&activityId=Module05a&registration=4dced8e9%2Df37e%2D430e%2D8cc6%2D3f868406c274&content=2c5%7E2a180c0j0a0p050f0d0b090g0u060v0w0D0E0z0C0x0B0s0t070q0y0r0A0e0l0k040i0h0o0n0m0%7E283%7E2431001A11%7E2V20101101111012110131101411015110161101711018110191101a1101b1101c1101d1101e1101f1101g1101h1101i1101j1101k1101l1101m1101n1101o1101p1101q1101r1101s1101t1101u1101v1101w1101x1101y1101z1101A11Ab%24%24%24%24%24%24000000010101010000000000000000800000000010&Authorization=0cd9437301b649ea8831b0ef6d1894eb&Content%2DType=application%2Fjson&stateId=resume

 

The old version was not posting in the standard form and was wrong. That’swhy Articulate changed it, it’s coming back to me a bit.  When you send a Content-Type of application/json, you have to sendan actual JSON block of data.  This is a form POST body in a traditionalsense (you can see the ampersands where the variables split).

 

Nowthey’re doing it right:

 

Content-Type:application/x-www-form-urlencoded

(samedata block)

 

We made changes to the lms last year to let it work with the incorrect header.  We needed it to track tin can statements out of the mobile player.  Once the Articulate mobile player was updated to use the correct standard, the changes we made were causing an error.  We are trying to find a way to implement a fix to allow both the correct standard and the incorrect standard to work.  The likely reason it worked on SCORM Cloud isapparently if you’re smart, you ignore the web-standard header that tells youhow to process the data, and treat the POST as a POST body always.

Shahid Ismail

Hi Ashley

We use moodle as our LMS here, I am not an expert in LMS and we do not have a team of experts either, infact i am the only one n the team who has some idea of moodle.

I had installed a plugin provided by Jamie smith and installed it in our moodle and when i test it from my personal ipad and some staff's ipad it works perfectly fine.

however when the client is trying to access the same on their ipad only then the unable to connect to the server issue comes up.

just wondering why it would work for me and the guys in the office but not the client.

Ashley Terwilliger

Hi Shahid,

I'm not familiar with the plug in you're mentioning, and I'm also not a Moodle expert. You may want to reach out to Jamie and see if he's aware of any difficulty with the plug in he created, Moodle and iOS8. The "unable to connect to server" issue is detailed here - and you'll see it's often a connection issue with the iPad or how the LMS is interpreting the data. 

I know we have a few community members who utilize Moodle, so I hope they're able to chime in here and share their experience as well.