Issue with Audio after Storyline Update 5

Hi, i just updated today to Storyline Update 5.  (Previously we were on version 3).

I'm having an issue with audio on the ipad.  I've published to HTML 5.  The ipad is v3 using OS 6.1.3

The course works fine in our LMS on a PC.

On the iPad, when you start each page the audio doesn't play.  It only plays if you touch the seekbar at the bottom of the player.

If you move to another page, either by using the next buttons or the menu, the audio doesn't play again until you touch the seek bar.

(This doesn't happen in our courses published with Update 3).

I'm attaching a very cut down version of this issue .story and the zip file.  This is 4 slides created from scratch to demonstrate the issue using example audio.

Can you help?

23 Replies
Nicola Redfearn

Hi - another update.

Redid the test course with WAV files and not MP3 files.  Still have the same issue.  the audio doesn't not play when the page opens.  If you press the seekbar it might paly.

In addition I've just noticed that the audio when it plays, only works through the headphones.  It does not work through the ipad without it.

In my WAV file version I added an extra page with layers and voiceover on the layers.  The voiceover plays on the layers, but not on the base page.

I've tested the course on my pc and it all works fine.  The voiceover is from courses that worked when published in version 1.3.

Please help as I need to get this course published and signed off very quickly.   What can I do to make the audio work on the ipad? Is there anywhere else I can test it?

Have attached the new .story file that was created with the WAV files. 

Ashley Terwilliger

Hi Nicola,

Thanks for sharing your files. I published the version to SCORM Cloud with the MP4 and the audio bitrate at 32 kpbs, and was able to successfully hear the audio at the start of each slide through my iPad speakers. I'm using an iPad mini with iOS7. You can view my published version here. Can you test that one and let me know if the behavior persists? Are you able to update to iOS7? 

Matt Leo

To add some further information on Misha's issue, these have been my experiences so far:

Using previous versions of Storyline (version 3 and 4), we have many courses that are published to HTML5 for iPad use on LMS.

Some of these courses have audio played explicitly from a button click trigger, while other courses have the audio playing automatically on the timeline. In Storyline versions 3 and 4, we had these set up and tested as working correctly on iOS 6, iOS 7, and possibly iOS 5.

Now with Storyline version 5, the courses that autoplay on timeline are not working properly (not playing at all) except on the latest version of iOS. Nothing has changed in these courses except that we are publishing with the latest version of Storyline.

The courses where audio is played explicitly from buttons are working correctly. Also, videos are working correctly whether played by either trigger or automatically.

Like Misha said, updating everyone to iOS 7 is not an option.

Ashley Terwilliger

Hi Misha and Matt,

I certainly understand that you can't force or require users to update to iOS7 on their iPads. I had another colleague of mine on the Support team test the link I previously shared in her iPad mini with iOS6, and the audio played as expected. Are you able to test the version I published here and let me know how that behaves for you? 

Matt Leo

I checked your sample course on my iPad (iOS 6 for testing). It played correctly.

However, many of our courses use custom navigation buttons and omit the default previous/next buttons. Also, we usually have the seekbar disabled. Could either of these be the difference as to why yours works and ours doesn't?

Thanks!

- Matt

Misha Milshtein

Nicola Redfearn said:

Hi, i just updated today to Storyline Update 5.  (Previously we were on version 3).

I'm having an issue with audio on the ipad.  I've published to HTML 5.  The ipad is v3 using OS 6.1.3

The course works fine in our LMS on a PC.

On the iPad, when you start each page the audio doesn't play.  It only plays if you touch the seekbar at the bottom of the player.

If you move to another page, either by using the next buttons or the menu, the audio doesn't play again until you touch the seek bar.

(This doesn't happen in our courses published with Update 3).

I'm attaching a very cut down version of this issue .story and the zip file.  This is 4 slides created from scratch to demonstrate the issue using example audio.

Can you help?


Nicola, I wonder if you found a resolution.

for our issue, I decided to revert to update 4 and the audio came back. While doing this we found out that folks report other issues with update 5, which is a shame - we had high hopes for this update, but will probably have to stay on update 4 for the time being.

Ashley Terwilliger

Hi Matt,

Thanks for testing that out! If you'd like us to test your file out with some of the custom navigation you have set up we'd be happy to. You can either share here, I can send you directions to share with me privately or you're always welcome to share with our Support engineers.

Misha,

I've just sent directions to you on how to share it with me.  

Evelyn Hamm

We have right now, the same issue. Audio will probably not play on iPads with iOS6. We are not using the default Buttons for prev & next. We are using a custom navigation. For us it is hard to explain to our customer that the Update5 is the problem. If there is no solution for this bug till now, please let me know how to downgrade Storyline.

Ashley Terwilliger

Hi Evelyn,

This is a known issue with the audio on iOS6 for courses published using update 5, and our team is working to fix it. You may want to first test your course to be sure that this is the issue you're experiencing by loading your course to SCORM Cloud or a web server to test on your iPads. While our team is working on the fix, you may revert back to Articulate Storyline Update 4, which can be downloaded here.
You'll want to first uninstall your current version of Storyline, install Update 4 (above), reboot your computer, then republish your course.
Jason Renshaw

Any update on this issue Ashley?

I'm having all sorts of problems on iOS 7.1 with MP4s published in Storyline in both version 5 AND version 4. On the iPad articulate app, the video plays but not the sound.

Quite frustrating, given the importance of video in so many of my SL courses.

Cheers,

Jason

Ashley Terwilliger

Hi Jason,

We reported the issue to our team regarding courses published with update 5 and using iOS6, but that sounds a bit different than your set up. Are you able to share one of these problematic courses with us so that we can do some additional testing on your file and see the video/sound behavior you've shared? If you'd prefer to not share here in the forums I can send you directions to send to me privately and you're also always welcome to connect with our Support engineers here. 

sivaji Bathula

Hi all,

I have a problem with html5 output on I-pad

The problem is I have 10 slides course some slides having audio file and some of them having videos and I published the course to scorm 1.2/ scorm 2004 html5 enabled out put, When I upload the zip file into lms and launch the course in I-pad mainly two issues are coming

1 Video's are not playing if i click on video to play it was keep on loading but not loading and playing.

2 I am running in portrait mode when I switch to landscape mode layout was not fitting well in landscape view.

We are using sumtotal lms.

I am hardly searching solution for these issues so please please help me on fixing these issues, I have a delivery on next week so please help me if anyone knows about these thanks in advance.

Katie Gokhshteyn

Hello, Key Learning!

This discussion is a bit older, so I want to make sure you get the most up-to-date help. A few quick questions about your environment:

  • What version of Storyline are you using?
  • What file type is the audio? (Storyline supports these file formats.)
  • Will the course be hosted on a web server or a learning management system?

If you can provide any sample slides with us for testing, that would be gold. We'll delete it after troubleshooting. If that works for you, send it along by using this private upload link!