Issue with Disabling Next button until users finish interaction

I used this tutorial http://www.articulate.com/support/storyline/how-to-disable-the-next-button-until-users-finish-interacting-with-a-slide to disable the next button.  

My issue is that even after they have clicked through all the layers, when they click the Next button, instead of letting the user move to the next slide, the "incomplete" layer still appears.

I followed the video tutorial to the letter, so I'm not sure what piece I'm missing.

Korey

5 Replies
Ashley Terwilliger-Pollard

Hi Korey and welcome to Heroes! 

Without seeing your set up, it's hard to say for certain - but a few things you'll want to check:

Trigger order is important, so you'll want to change the state of items or variables at the top of your trigger panel

Is there another trigger for the incomplete layer that is still being fired, regardless of the conditions? You'll want that trigger to be set if the conditions are not met

Have you set your slide properties to "resume saved state"? 

If you're  still having difficulty and would like us to take a look you're welcome to share your .story file here by using the paper clip icon to attach it. If you'd prefer to share it privately you can also send along here. 

Jenny Watkins

Hi all,

I've followed the tutorial here:

http://www.articulate.com/support/storyline/how-to-disable-the-next-button-until-users-finish-interacting-with-a-slide

It works in preview mode (preview slide AND preview scene) but it does not work when I preview the entire project.

Has this issue been reported before?

Thanks,

Jenny

Ashley Terwilliger-Pollard

Hi Jenny,

Does it not work on any slides when you preview the whole project or just certain ones? Are you using the same variable for each slide and resetting it at the start of the slide? It may  help us figure out what's happening if you can share your .story file here with us (you can attach it using the paperclip icon).