Issue with Drag and Drop

I am having an issue with a drag and drop interaction. On one slide, it is working fine. You can click the object (pipette) and move it over the test tubes to trigger the state change from hidden to normal. The object moves fine and the trigger works.

On the next slide with this interaction, this isn't the case. I've tried several ways of working the interaction. The first way was set up the same, but a new object went through a state change (starch and albumin drops). When I drag the pipette, it moves off from where I clicked in an odd manner. Then, when I drag it over the test tube, nothing happens. I have tried having the "Hover Over" selected as just the test tube, the test tube group, the "albumin drops" and everything on that part of the screen-- nothing works.

Here's a video showing the issue. Any insight is appreciated!

3 Replies
Walt Hamilton

Two things:

The Albumin pipette is part of a group. SL and groups don't play nicely together to start with, and especially not with drag and drop actions, and especially not with state changes. Ungroup it, and it will drag normally, although it changes test tube 3 as soon as you move it. You might want to change the trigger so it doesn't include the albumin beaker.