Issue With Publishing Content

Hi All. I wonder if anyone else has had the issue that I am experienced today. 

I made some tweaks today to a course I have been working on, and published it in the normal way, before uploading it to Amazon S3. However, when I tried to make the files "public" on Amazon it told me there was an error with one of the files. After combing through it all, I found out it was a JPEG. The course plays fine, except that this JPEG didn't appear. (Although it was appearing fine yesterday.)

I republished the course and the same thing almost happened. The JPEG (which I hadn't touched) was fine, but two other files (one sound effect and one very small PNG) were suddenly now the problem.

The big issue for this is that I knew my client would want to review the material on an iPad. The course plays fine (missing the rouge elements) on Articulate Player, but when you try to download it for offline browsing, tha app says no because some of the files are missing.

In case my story file had got corrupted, I resaved it, and tried uploading it to TempShare. That seemed to work ok until, again, I tried downloading it onto iPad and got the missing files message.

I tired resaving it again and uploaded it to Amazon and it worked this time! The only thing I did differently was use IE9 rather than Chrome (which I also used for the TempShare upload). However, I have been using Chrome and Amazon for my Articulate uploads (on a variety of different PCs) for well over a year, so am not sure why it would suddenly be a problem. (I don't think there has been a Chrome update since yesterday, which is the last time I published without any issues.)

Has anyone else experienced this? I hope it is just a Sunday thing! 

5 Replies
Christine Hendrickson

Hi James,

You mentioned that everything worked out on your last attempt, when viewing with Internet Explorer, but were you able to get it working on the iPad as well? 

Also, I know you mentioned you've re-saved the file a couple of times already, but are you saving the project as a new project file, or overwriting the original file? If it's a possibly corrupted file, it may be best to import the course into a new project entirely and try it out.

James McLuckie

Hi Christine 

Thanks for the detailed reply. Yes, I got it working on the iPad. I also went back to the original file and published again from that, and got it to upload to Amazon S3 no problems.

Hopefully, it was just a temporary glitch! However, it has made me a little worried in case it happens again. 

What is the best way to import a story to another file? Copy and paste, or some other way? 

Thanks again.

Christine Hendrickson

Good morning James!

That's wonderful I'm happy to hear it's working on the iPad, as well

Personally, for importing, I would use the actual import feature instead of copying. Why? Because you'll be able to pull over more data from those slides. In some instances, copying and pasting can lose some triggers and layer settings. You may have already seen it, but we do have a pretty awesome tutorial on Importing from Another Storyline Project. I've used this a couple of times with the same project I'm working on, actually. It's a little safer than copying things over or duplicating, sometimes.

I hope this helps!

Have a great day!