Issue with showing correct answers on the incorrect layer

I would like to show our learners the correct answers if they have answered the assessment question incorrectly.  I have managed to do this with the creation of a custom state, Correct (see first and second screenshots). 

However, the issue arises when the learner selects their responses and clicks the Submit button.  As you can see in the third screenshot, the second and fourth option were selected.  However, when the incorrect layer appears, the green text indicates the correct responses, but the second option no longer shows the checkmark. 

I have exhausted my knowledge to have the checkmark appear for any of the items selected by the user, but the States only allow the Selected state to have the checkmark.  I would super-impose a checkmark, but we have to shuffle the answers, so I cannot place a static image over the correct options.

Has anyone else encountered this and have a solution?  I am open to almost any options.  Thank you.

3 Replies
Ashley Terwilliger

Hi Paul,

You may also want to share a copy of your .story file so that folks in the community can take a look at this slide and what you've already got set up.  That way they can play with the design decisions you've already made. You can add it here using the "add attachment" button at the bottom of the reply window.

Alyssa Gomez

Hello Paul!

You're right that the 'Selected' state is the only state that allows for a check to be in the checkbox. However, you might consider using a checkbox with a green fill for the 'Correct' state. I made that change to your file and attached it here. Take a look, and let me know if this will work for you! If not, maybe the community will have other ideas to share. :)