Issues viewing content in iPad App from IIS server

May 13, 2013

I am fairly new to Storyline and I'm having an issue with the Articulate App for iPad. I have published a sample Storyline with the following settings: "WEB", "Include HTML5 output", "Use Articulate Mobile Player on iPad", and "Allow downloading for offline viewing". I then uploaded the output folder to my web server (IIS) and the following happens:

Viewing Flash version from computer: Works

Viewing HTML5 version from computer: Works

Viewing HTML5 version from iPad (by going to story_html5.html): Works

Viewing iPad version in Articulate App: Does not work ("Cannot Download Content" error)

In the process of debugging, I also uploaded this to another server (Apache/Linux) and all of the above methods (including the Articulate iPad App) worked just fine.

I know that the issue has something to do with the server since it works just fine on another server and it can play in Flash or HTML5 mode. Taking a few shots in the dark, I enabled "Directory browsing" on IIS and made sure that my MIME types for .js, .gz, .xml, and .html matched the working server. Neither of these fixed the issue. If anyone can offer any help to this problem, I would be very happy.

Thank you,

4 Replies
Christine Hendrickson

Hi there Ben,

Quick question - does your server require authentication or a username and password? If so, you might want to see if you can move the content into a public folder, or try temporarily disabling the authentication feature on your server.

You may also want to check out this article:

"Cannot Download Content" error in the Articulate Mobile Player


Ben Perkins

Hi Christine, thanks for your prompt response. Unfortunately, the files are in a public section of our website already. I can view them just fine from a computer without logging in or supplying a username and  password. I have also read through that article and neither of the two listed solutions work in this particular case.

Christine Hendrickson

Hi Ben,

Thanks for the additional information!

I just noticed you didn't mention the FLV MIME type in your original post. Have you checked to make sure that's set up as well? 

Here's some information I found:

"Additionally, if you’re using a Windows/IIS server and have added any Flash video (.FLV) to your content, you’ll need to make sure you add the .FLV MIME type to your server. This should be pretty easy for any Web host or server admin to do."

You should be able to enable it by following these steps:

  1. Right-click the site in IIS and select Properties.
  2. Select the HTTP Headers Tab.
  3. Select File Types.
  4. Under the MIME Map section, select New Type.
  5. Type ".flv" as the associated extension and "video/x-flv" as the content type.
  6. Click OK.

If the course still will not launch in the Articulate Mobile Player from your server, it might be a good idea to contact our support team. Hopefully they'll be able to give you some additional information and suggestions.

You'll be able to attach the .STORY file on the second page of the following form:

Articulate Support - Submit a Support Case

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.

Thanks again, Ben!

This discussion is closed. You can start a new discussion or contact Articulate Support.