issues with story_html5.html file

I've now tried to post this discussion 3 times. Hopefully this time works. Having issues with a published project.

Here's the directory structure:
http://www.execulink.com/~brenkie/CEDP/OBE/

These links work:
http://www.execulink.com/~brenkie/CEDP/OBE/story.html
http://www.execulink.com/~brenkie/CEDP/OBE/story.swf

This link does not:
http://www.execulink.com/~brenkie/CEDP/OBE/story_html5.html

9 Replies
Kyle Mackie

I've done some further investigation. Here's a link to a version of the project that works fine:

https://drive.google.com/open?id=0B6HLNAhG_t3PdXlsSXZpdWZkOUE

When I publish it, everything works fine.

When I import a custom player (file attached), the story_html5.html file does not play. The custom player file is exported from another (fully operational) project. Any ideas?


-Kyle

 

Steve Flowers

That's really strange, Kyle. Here's what I'm seeing:

First it kicks this warning (shouldn't matter and I don't think that it does). This is likely a common error in some configurations.
The provided value '0' is not a valid enum value of interface OscillatorType.

When it tries to load this slide, it fails. Going direct to the link, it looks like the slide isn't there.
https://www.execulink.com/~brenkie/CEDP/OBE/story_content/slides/5twe0sj69OK.xml

What's even more strange... it shouldn't be attempting to load that resource at all. There is a 5twe0sj69OK.js file in the mobile/slides directory and a 5twe0sj69OK.swf in the story_content/slides directory. 

I don't see how the notes/transcript link could be affecting this. It's all very strange. I'm sure this is an interesting problem for the QA / Support / Engineering folks. They tend to love consistently reproducible problems:)  I'd definitely submit this thread as a support ticket. 

Kyle Mackie

Isolated the problematic scene and then the problematic slide (2.11, I
think). Rebuilt the slide. Published, and IT WORKED.

Then realized I forgot to paste in the slide notes. Published and IT DIDN'T
WORK AGAIN.

Wracking my brain. Thought it might be a length or formatting issue (which
seemed ridiculous).

Ended up having to re-type (!?) the notes, and it works.

I'm definitely taking today off.

-Kyle

Steve Flowers

Hey Kyle - 

Bah! Those are the ones that suck! It could have been an odd character in the notes field. If you copy into something like text wrangler or notepad++ from the one that doesn't work and a square appears - that could be the culprit. 

I just saw the identical issue a few days ago. Threw me for a loop and I completely missed the connection to what you're seeing here. Sorry:(