javascript command not working when published story is downloaded from google drive?

Short story:

  • Javascript trigger to generate a custom certificate and open the print dialogue menu does not work when published story is downloaded from google drive. Why is this?

Long story:

  • At work there is a tablet computer which is not connected to any networks or the work network - it is only for construction contractors to complete some EHS training
  • The last page of the EHS content contains a "print me" button - when users click this button it triggers the execution of some javascript, which generates a certificate of completion and opens up the print dialogue (the tablet is connected to a bluetooth printer)
  • Previously, I created the EHS module on my work laptop, published to "CD", transferred the published files onto a USB, and transferred onto the tablet - no problems
  • This content must now be updated tomorrow
  • However, as I have just discovered, our company has put in additional controls around the use of USBs. When we put in a USB, it gives us the option to either use it as read-only, or to encrypt it, meaning the files on it can only be accessed from other work computers. The tablet is not set up as work computer - as I say, it's just a standalone device, not connected to any of our work networks.
  • I tried to workaround by uploading the published files to google drive, and then downloading them onto my home computer, where they could then be loaded onto the USB.
  • However, when I download the published files from Google drive, everything works except the javascript command. When you click the "print me" button literally nothing happens. I have tested this on both home and work computers so it's definitely the transfer from google drive that is the issue - the same content works perfectly on my work computer without the transfer step

 

Any ideas why this is happening and how it can be rectified - today, preferably! 

6 Replies
Michelle M

Hi all,

I did a workaround for my particular situation (basically built the course again on my home computer and transferred onto USB from there) but I'm still very intrigued as to why the javascript would stop working when the .story file is transferred through google drive(I also tried wetransfer with the same results). 

If anyone has insights to this I would love to hear them.

Phil Mayor

The exe file is there to ensure that content that is designed to run on the web can run locally (i.e not from the intranet/internet).

The CD output has changed recently so it is web based rather than flash based, but still runs via internet explorer only, it may be you machine has javascript disabled on IE or restricted or you are not using the exe file. It is unlikely to be the file transfer that is breaking it.

Michelle M

OK, so I stripped everything out of my course except for 1 question and the 2 other slides of relevance for my javascript trigger.

I then

  • Published to "CD"
  • Launched the published .exe file
  • Tested javascript trigger - works perfectly. A certificate is generated and print dialogue menu opens as expected.

On the same computer I  then:

  • Uploaded entire published "storyline output"  folder to google drive
  • Downloaded the folder (onto the same computer) - the folder downloads as a zip file
  • Extracted all files
  • Launched the downloaded and extracted .exe file
  • Javascript trigger - does not work

Given that I am using the same machine in both instances, and am indeed running the .exe file,  it must be something during the zipping/extracting process that causes this issue? 

I have attached the .story file with the relevant trigger, if anyone wants to play around themselves.