Jump to URL not working (Storyline 2)

Hi - I have a button with a trigger to jump to a URL, which I have tested (in the trigger settings). However, when I publish the file to the web (yes, outside local computer), the URL link doesn't work. I have found numerous articles regarding the same issue from other users but no resolution... All end in 'please send your project file to us so we can look at it'.... so I can't fix it myself.

I have tested it using Chrome and IE - neither works. 

14 Replies
Stephanie Harnett

Hi Jane. Is there a specific error message that appears? Is there a 'page not found' error or is there another kind of error happening? Can you do a screen capture of what it is that you see in terms of the failing URL post published and launched from a web server? Can you see the URL in the address bar of the browser? Is it formatted correctly? Does it need http or https?

Jane Booth

Hi Stephanie - I'm not getting any error at all - when I click onto the button, nothing happens. The address is https - tested in the trigger settings and works fine. Just doesn't do a thing in the published file on the web. This is the link: https://adobeformscentral.com/?f=v87VQ3DnK4ZTKJq1-jptUQ 

Wendy Farmer

Hi Jane

 

works fine for me in IE v11.

There seems to be a 'space' in the address when you copy and paste it into the trigger box.  I removed the space and it was fine.

I've loaded into dropbox as well...here is the link

 https://dl.dropboxusercontent.com/u/23629756/JumptoURL%20-%20Storyline%20output/story.html

 

Stephanie Harnett

Hi Jane. I can't seem to replicate the error so am not sure what it might be. Attached is a story file with a single button that has the URL on it which you supplied above. Below are links to live versions of both; one done in SL1 and the other in SL2.

http://stephanieharnett.ca/sl/forums/url-sl1/story.html

http://stephanieharnett.ca/sl/forums/url-sl2/story.html

Stephanie Harnett

Hey Wendy. Yeah, I tested this on 32bit and 64 bit machines on IE, Firefox and Chrome locally and from my web server - without changing a thing (just copy and paste the URL supplied by Jane), it worked. So I'm not sure what's preventing it from working for Jane. BTW - I haven't bumped into you here on the forums before - a digital hello and nice to meet you. : )

Jane Booth

Hi again Wendy and Stephanie - sorry about the reply lag - I'm in Australia, so with our time differences, it can appear that I've dropped off the planet, but I'm still here :)

I'm wondering if there's a problem with my web settings. I have tried two things: the first is to have the result slide 'jump to URL' when the user reaches the 'success' layer (which doesn't work) and the other is to have the success layer link to a slide with the form (web object) embedded. This is not working either....

http://www.lotus-elearning.com.au/demos/test-url-link/ (in this case the Jump to URL doesn't work when linked to the green button at the bottom of the success layer).

http://www.lotus-elearning.com.au/demos/test-embedded-form/ (in this case, the embedded form doesn't display at all on the final slide)

I have attached both test projects. Any ideas? 

 

Wendy Farmer

Hi Jane

Hello from sunny Gold Coast.

Ok..I took your Test_Web_1.story.  Published it and get a 404 error — get the same error when I access the link you sent above.

I added the jump to url link to the green button on the review slide.  Published and uploaded the file to dropbox and scormcloud.

Here are results

Dropbox — click the green button and the webform opens in a new window -  I am not using the web object slide.

If you want to send me your email...I can send you a link to the ScormCloud output

I haven't tested story 2 yet