key presses not working

I thought I'd try out some of AS3's new animation and collision detection features.  I started by creating a simple asteroid game. I thought it would be nice to use keypresses to trigger the movement.  However, I can't seem to get any keypress to work.  I've tried adding the keypress on the right/left keys as well as the A and D keys.  The same animation works with button presses if I insert buttons to create the interaction.  I've tried this is in both preview and publish mode.  I've checked the published version on a virtualized Windows 10 env. (VMWare) as well as in Chrome on OS X.  I've tried removing any other reference to trigger the motion.  I've tried recreating the interaction in a new .story file.

 

But still no dice.  The keypress interactions appear to not register at all.  I'm including the very basic .story file if you're interested in looking at it.  Any ideas why my keypresses don't seem to register?

6 Replies
Peter Rich

So, I created another demo on a windows-only machine.  Same situation, but the only way to get key presses to register is to first click on the object that the trigger is registered with (see attachment for the new demo).  I thought that perhaps it was an issue with the object needing to be initialized within the player first.  So, I tried creating an entrance animation on the object or another way of initializing it without having to physically click on the object in question.  Unfortunately, that doesn't seem to work. 

In short: in order to use key presses you must first use a mouseclick on the object that is attached to that trigger.

This behavior makes little sense and must be a programmer's oversight.  The point of using keypresses is to provide a different control mechanism/interaction than through the mouse.  Is there any way to simulate a mouseclick so that the user doesn't actually have to click in order to initialize a keypress?

 

 

Alyssa Gomez

Hey Peter, 

Thanks so much for those details and for including a sample file. We're seeing an issue in Storyline 3 where triggering a motion path by pressing a key does not work properly. Like you said, you have to click the object before it will move along the path. This is definitely not intended behavior, and we're looking at next steps for a fix.

I really appreciate you bringing this up, and I'm sorry it's giving you headaches. I'll tag this thread to be updated as soon as a fix is launched!