Keyboard focus moves strangely on question slides

When tabbing through my course (in Preview mode) to test its accessibility, I've noticed that on any question slide, after hitting Submit, the keyboard focus moves as follows with each press of tab before finally moving to the feedback layer:

  1. To the audio button
  2. Disappears
  3. To the now inactive submit button
  4. To the audio button
  5. And then finally to the feedback layer.

It does this on every question slide. Is this expected behavior for Storyline 2 Update 5 (1505.515)? Is there a way to fix it?

Also, the keyboard focus also never seems to go to the Main Menu button that I have set up on the top of the player on any slide.  How/where is that controlled?

 

1 Reply
Ashley Terwilliger

Hi Fiona,

Keith and I were just discussing this exact set up in another thread - and after some testing I reported it to our QA team this am. So your timing is fortuitous at least although not likely what you wanted to hear. 

As I mentioned to Keith, I am not able to offer a time frame in regards to when I'll hear back from our QA team, so in the meantime I'd look at using the workaround of creating your own custom feedback layers or including directions to users about how the tabbing will work on the feedback layers as I shared with him. Once I have additional information to share, I'll update you here as I've linked this thread to the report filed with our  QA team.

Also, as an FYI we're on Update 6 of Storyline 2 now so you may want to download and access the update here.