Launch Issues With SL 2, update 7 using the Articulate Mobile Player App.

Good morning.  We are experiencing issues with iOS 9.  Currently as a company we are prohibiting updating to iOS 9 as there appears to be an issue with launching SL 2 courses through our LMS with the Articulate Mobile Player App.  I have SL 2 Update 7, and the Articulate Updater.  When attempting to launch  a program from the LMS to an iPad with iOS 9 installed, the Launch window appears.  Tapping the launch button does nothing.  However, if you hold down on the accented Launch button, the "Open In Articulate" window (see attached photo) finally shows but includes all of that machine code (?).  This is not very intuitive from the previous iOS.  

Was wondering if anyone else is experiencing similar issues.  We are using the Tin Can capability on our courses. All works great on iOS 8.4.1.  Only iOS 9 is causing these issues.  I have all the current iOS 9 support updates.  We have submitted a case.  

8 Replies
Ashley Terwilliger

Hi Jeffrey,

I just saw someone in another thread show the same image - but I haven't heard or run into it yet myself when launching new courses published with Update 7 or updated with the Articulate Updater for iOS9 issues. Did you test it on an iPad that had not previously accessed that link before? I know a few users ran into the issue with the course not launching after update, but it was based on Safari trying to access a cached copy of it. If you'd like to share the link here I can test on my iPad and you could also look at clearing out the cache/history of your Safari browser and deleting the course from the Mobile player so that it has a fresh reload. 

Jeffrey Foster

Hi Ashley. Thanks for responding. Yes, our Lead IT Analyst had submitted the same screen shot. I missed the fact that he did that. Sorry for the duplication. I am trying to see if we can get you a link to our company LMS so you can view. The programs work, but in order to launch the program, one has to "hold down" the accented Launch button for more than a second and eventually the "open in Articulate" window shows up. But it has all of that machine code included in the window.

To test this on devices with iOS 9 I used my iPad mini since we are not allowed to update to iOS 9 at this time on company devices. Our Lead IT Analyst, Senthil was able to duplicate the problem on his iPad last night.

I am working to see if I can send you a link to our LMS. Is this address good for the response?

I also see you have responded to Senthil. We will get together on the next communication. Thanks again.

Jeffrey L. Foster
Instructor, Developer
NetJets Inc.
4111 Bridgeway Avenue
Columbus, OH 43219
T: (513) 979-6067
C: (614) 302-0163
F: (513) 979-6626
E: jfoster@netjets.com
www.netjets.com
NetJets(r) Inc. is a Berkshire Hathaway company.

*** *** ***
This message contains information which may be confidential and privileged. Unless you are the addressee (or authorized to receive for the addressee), you may not use, copy or disclose to anyone the message or any information contained in the message. If you have received the message in error, please advise the sender by reply e-mail and delete the message.

Ashley Terwilliger

Hi Jeffrey,

No worries on duplication - but I'm happy to hear it's that you're working together as it means its not likely to be a wide spread issue. If you can send me a link to your LMS and need it to be private can you share with me here?  Otherwise you can post it in the forums, but then anyone in the forums can see it.

Also, just an FYI that responding via email includes your signature here. You are welcome to edit the post to remove that if needed, but it's no trouble on our part. 

Jeffrey Foster

Ashley,

I have provided you with a link to our LMS via the private access along with login and pw. Thanks for responding.

Jeffrey L. Foster
Instructor, Developer
NetJets Inc.
4111 Bridgeway Avenue
Columbus, OH 43219
T: (513) 979-6067
C: (614) 302-0163
F: (513) 979-6626
E: jfoster@netjets.com
www.netjets.com
NetJets(r) Inc. is a Berkshire Hathaway company.

*** *** ***
This message contains information which may be confidential and privileged. Unless you are the addressee (or authorized to receive for the addressee), you may not use, copy or disclose to anyone the message or any information contained in the message. If you have received the message in error, please advise the sender by reply e-mail and delete the message.

Ashley Terwilliger

Hi Jeffrey,

Just wanted to give you an update here - our QA team is still looking into fixes for this issue, but in the meantime they did identify a workaround. They shared that you'll want to do the following:

Open the amplaunch.html file in the output folder in a text editor like notepad.
Search for: <a id="launch" href="#" class="button">Launch</a>
and replace it with: <a id="launch" href="#" class="button" target="_top">Launch</a>