Layers overlapping when publishing to Word

I need some help please with text overlapping when printing my Storyline file. A number of my slides have layers and the base layer text boxes are hidden and don't display when viewing the file. However, when I publish the file to Word the hidden base layer text boxes show on the layer slides so I end up with text overlapping. Only one of the slides with layers prints OK and I've checked the slide properties and triggers and base layer objects and the settings are the same for all the slides with layers. Is there some other setting I should check?  I know there's an option to not print the layers but I don't want to turn that off as I need to show what's on the layers. Any help would be much appreciated. Thanks

34 Replies
Ashley Terwilliger-Pollard

Hi Jen,

I'm trying to replicate this on a new file, and I don't have photoshop so I just inserted images and or shapes - and my file consistently shows everything upon publish to Word. Can you take a look at the one attached here. You'll see there are base layer images  (with and without states) and then slide layer images that are with/without states and with/without being grouped. Everything appeared in my publish to Word. I'm also using Windows 8.1 and Office 2013.. If you see something different can you let me know about your set up? 

You mentioned a colleague has it working fine in Storyline 2 Update 9, and that you reinstalled, but I wonder if you need to do the full repair in case the installation caused issues with Storyline? 

Jen McIntosh

The problem doesn't occur with shapes, only with images (they're recolored on the states). I'd already created a version with shapes yesterday and it worked just fine, sorry I could have saved you the trouble. I'm using 64 bit Windows 7 Pro Service Pack 1. Office 2010 for Word.

Yes it works fine in update 9 on both my machine (before I upgraded as well as after I downgraded) and on a coworker's machine that was never upgraded. I have to completely uninstall storyline every time I downgrade to update 9 (and have rebooted before updating just in case). I'll go ahead and try the full repair trick though.

Jen McIntosh

Did the full repair, and can still duplicate the error on a new file (attached along with an image). Just to be sure you're doing all the same steps when trying to replicate:

  1. Start a new project and save it locally. Place anything on the base layer, it doesn't seem to matter.
  2. Create a new layer. Change the layer setting to check "Hide objects on base layer" ("Hide other slide layers" should be checked by default).
  3. Insert an image onto that layer. Either copy/paste it, or insert it again so that there's 2 images.
  4. Add a visited state to image 1, and recolor it (don't really think the recoloring is necessary, it just made it easier to see when it was clicked on in my other tests).
  5. Export to word with "show layers" and "show slide notes" checked, screenshot size medium. Image 1 will not show up, but image 2 will.

 

Wendy Farmer

Hi Jen

I'm using SL2 update 10 and did your test.  

If I select the option on the layer 'hide objects on base layer' - neither of the images on my layer display BUT if I uncheck hide objects on base layer and then go to the timeline of the layer and turn off the picture on the base layer from there - it works and both pics on my layer display in Word.

 

Jen McIntosh

Finally someone can duplicate the problem! Yes that is correct Wendy, if you uncheck "hide objects on base layer" then the images will show just fine. And yes if you hide the base layer image from the timeline of the base layer then it won't show and the layer images will. My problem is that I only need to "hide objects on base layer" when viewing the other layers, not hide the base layer image completely. In my actual project it is a button which requires interaction. It worked as expected in update 9, but not in update 10. So in trying to fix the issue where hidden objects on the base layer were showing, they accidentally hid certain situations of layer images as well.

Ashley Terwilliger-Pollard

Hi Jen,

First off, thanks for the detailed steps - as that was exactly what I need to replicate it. Also, appreciate you testing it as well Wendy! 

You can hide individual base layer items from the layers itself using the timeline. What you'll see is the bottom of a layer timeline has a section for base layer objects that is collapsed and if you expand that you can use the little "eye" icon to show/hide certain elements. That should work for you in the meantime and I'll also get this in the hands of our QA team for additional investigation based on the change from Update 9 to Update 10. 

Thanks for your patience as we worked through this one.