Letters 't' and 'f' going missing in Storyline 360 for small population of users?

I am getting some really odd feedback for one of our Storyline 360 courses (published for HTML5 with Flash backup). Has anyone encountered this / knows what is going on? Unfortunately I haven't been able to replicate the issue. Here are some of the comments the course is getting:

  • "Why are all the t's and f's missing?"
  • "Most all T's and F's are missing"
  • When opened in Explorer there were missing letter so it was very hard to read.
  • "Some of the slides had letters missing"
  • "All the missing letters were very odd. Was there a point?"
  • "The content was difficult to read mostly because of there were letters missing throughout the slides. It seemed mainly all the "t's" and "f's"
  • Why are all the t's and f's missing? That was very strange and might be very hard for people with visual difficulties.
  • several letters were missing difficult to read.
341 Replies
su elias

Good morning Leslie, 

This is really becoming a pressing issue for me. My target group are European Military Missions, with very strict security rules. I have been at their office in Brussels, and they cannot even access 'Custom level' in the IE security settings. The course needs to be online half October, so hoping there will be a fix by then.

Su

Ashley Terwilliger

Hi all,

You'll notice that this discussion started some time ago, and we shared the initial workarounds and fixes. Since that point, our team has been digging deeper into this issue after discussing it in detail with many customers, and you'll see my colleague Mike committed to a fix about six months ago.

Our team is in the final stages of testing the fix before we ask customers who ran into this issue previously to help us test it too. Once that is complete, you'll see it available in a future Storyline 360 (and Storyline 3) update, and we'll announce that here when it's ready.

I'm sorry I can't offer an ETA at this time, but please know we're committed to providing a fix as soon as is possible.

Perry B

Michael, 

Thank you for linking to the forum post I did. That was a good idea to add it to this post. The more people that can test my temporary fix the better! Half our student base (which is pretty large) is still on some version of IE. Articulate needs to keep working on a more permanent solution.

Thanks,
Perry 

Alex Nevels

I'm having this same issue with a course, too. It's more than the t's and f's, but i's and n's and a few others. We used the same font as in previous years (basically made updates) and are now experiencing issues, randomly, and largely in IE. It's really difficult to troubleshoot because we can't replicate. See attached image.

A few questions:

1. For those who have had this issue, do the users ALWAYS have the issue? Or is it intermittent? Is it something a "clear your cache/restart and try again" thing can fix?

2. The Help article pertaining to this topic is difficult to implement because of so many departments and administrators and various users/devices. The easiest one to explain would be for us to add our LMS site to the "trusted sites" -- but the only admin suggestion is to change the downloading fonts for this site. I'm assuming adding the site as trusted fixes, yes?

We just launched the 2019 version of this course today and hopefully won't have this happen to too many...

Alyssa Gomez

Hi Alex,

Those are great questions--let's dive right in:

  1. We've seen that users who have this issue will always run into this issue, unless they follow the steps detailed in this article
  2. Following the steps to add your website to their trusted sites in Internet Explorer should fix the issue. If you hear that the issue persists after your website is added to the trusted sites list, be sure to let us know here
Alex Nevels

That's helpful. Another question -- is it generally with non-system fonts? Could swapping out everything to something like Arial resolve the issue? 

It's hard to troubleshoot when you can't replicate :)

//

As an update, the affected user restarted their machine, and it worked as hoped. They were using IE11. 

Leslie McKerchie

Hi Alex,

I appreciate you chiming in with an update and glad that it's working for your users now.

To address your additional question, we've seen users have issues with all types of fonts, including Arial, so that's not a solution we've shared.

I certainly understand the frustration of tracking down an issue you cannot replicate :)

Dena Fife

I've been working with a client for a year and this is the single issue that repeatedly gets brought up in all our testing. I have tried to deter them from using IE, however, for some of their users, the only browser they can use at work is IE. I have switched fonts to a more neutral font that was recommended (I'm using Calibri) and I'm using Articulat Storyline 360. I know you said that this has been fixed, but they are still bringing this issue up and  I'm not sure what else to tell them or recommend.

Lynn Wonsick

It is a browser setting issue with html.

The Font Download Setting Is Disabled in Internet Explorer

The font download setting in Internet Explorer is enabled by default, but some users or organizations may disable it. If learners have the option to enable it, here’s how to do so:

In Internet Explorer, click the gear icon or the Tools menu, then choose Internet options.
When the Internet Options window appears, select the Security tab, choose the Internet zone, and click Custom level.
When the Security Settings window appears, scroll to the Downloads section and enable the Font download setting.
Click OK twice to save your settings, then close and reopen Internet Explorer.

If you can’t enable the font download setting described above, their IT department may be able to add the website to their trusted sites in Internet Explorer. Here’s how:

In Internet Explorer, click the gear icon or the Tools menu, then choose Internet options.
When the Internet Options window appears, select the Security tab, choose the Trusted sites zone, and click Sites.
Enter the website where your e-learning content is hosted, then click Add to add it to the list. Trusted websites must start with https://
Click Close, then click OK to save your changes.
Close and reopen Internet Explorer.
 

If you try these two things and it still doesn’t work, Google Chrome may work out better for you.

 

Tom Eichhorn

Hi, I'm also a victim of this annoying bug, that all fonts switch to a poor spaced TNR, if IE-security settings denies to download webfonts.
And I'm very surprised that Articulate actually proposes to change the security settings of company browsers rather than providing a way to use only local system-fonts like Arial, Verdana etc...

I tried several workaround solutions, first I replaced all font-face/font-family entrys in all CSS to:

@font-face {
font-family: Arial, sans-serif;
font-style: normal;
font-weight: 300;
src: local("Arial")
}

Only result: All framework-texts like: next, back, menu, resources... are displayed in sans-serif instead of TNR.
All content-texts remain TNR.

Next, I made a little change in "app.min.js":

Open app.min.js (located in "html5\lib\scripts") and search for:
fontFamily:"font-family"
Remove the dash so it says:
fontFamily:"fontfamily"
Now all missing fonts are displayed in a sans-serif font instead of serif TNR.

Until Articulates provides a proper solution on that issue, I will use that workaround.
Since this font-issue is a total dealbreaker for us, we are forced to move to another elearning development software if there is not a solution soon.


My environment:
Articulate 360, export HTML5 only

Alex Nevels

We're having more and more learners with HTML font issues using Internet Explorer. Putting the issue on the learner (really the client) is not an acceptable solution, especially when Storyline markets IE11 compatibility. It's bad UX. Storyline's competitors don't have this issue, and if you search HTML5 missing letters, you won't find it to be a common web development issue either.

As a result, we are having to abandon Storyline 360 for future development, and it's incredibly frustrating. We have a great workflow with Storyline -- but now are having to switch over to Captivate.

In an effort to help get this resolved ASAP, here are a few more things we've noticed:

1. If you have the user restart, it works. If this is an enable trusted fonts issue, I wouldn't expect this to make any difference.

2. It usually works for a few days for a user, and then stops working again until they restart.

3. It ONLY happens on IE11. 

4. All fonts are affected -- you can't use system fonts to fix the issue. 

5. It's not just letters T & F. Some slides are so affected you can't even guess what they are.

6. I was unable to get any fix by adjusting padding/paragraph spacing.

For any Storyline support staff -- is there any update, or any ticket progress I can follow on this? This has been an issue for months and really should be a priority to be fixed. I see multiple updates have been made to Storyline since the issue has been identified, but none addressing this issue.

 

 

Ashley Terwilliger

Hi Alex,

I'm sorry for all the trouble you've run into! The inconsistent nature of your experience makes me wonder if something else besides the issue detailed in this discussion is impacting you. I've gone ahead and opened a Support Case for you so that our team can reach out, and with your permission, they'll want to take a look at some files and screenshots of what you're seeing. We'll delete those when done troubleshooting, and I'll follow along to share any relevant updates here too.