Lightbox trigger error

I am wondering if anyone else is having this problem.

In my course I have a lightbox that pops up if the learner tries to access part of the module when they haven't completed the relevant quiz.

It pretty much just says 'you must do the quiz first to access this part of the training'. They can then click on 'ok' and it should close the light box and directs them back to the introduction screen. This is based on two triggers on the 'ok button':

"close lightbox when user clicks"

and

"Jump to 1.1 Introduction when user clicks"

If I put close lightbox first it closes the light box and the slide they aren't supposed to be able to access plays.

If I put the Jump to.. first it jumps to that slide but in a lightbox.

I know from my Storyline training this should not be happening, you should be able to get both triggers to execute. Can anyone point ot what i may be doing wrong?

Thanks

16 Replies
James Brandwood

Here are example of what is happening.

I have included an example file of having both the 'close light box', and 'jump to..' first. I have also included published versions of this.

I also noticed that the seekbar moves in the background when the lightbox is showing but none of the interactions take place. 

Christine Hendrickson

Hi James,

Thanks for the files! I took a look and I saw how the slide was actually opening up in the lightbox. I removed the initial trigger from the "OK" button and the trigger to close the lightbox. When I tried it again, it looks to be working properly. I'll upload the file so you can take a look. 

Currently, it goes back to the Introduction slide after the lightbox closes, but you should be able to edit that so it goes to your Quiz slide, or any other slide you'd like to display.

Let me know if this works for you,

Christine

James Brandwood

Hi Christine,

Sorry to take so long to get ack to this, it is deadlines galore here at the moment and an IT update o our system has had a no-so great effect on staff being able to run training.

When I run a preview of your version I et the same bahviour as when I run my own versions. I press ok and the lightbox goes away and the Content 1 slide begins. It doesn't jump anywhere.

Christine Hendrickson

Hi James,

Maybe I'm not understanding what you'd like to do, then. When I force the light box to open (by clicking on the next section of the course), I no longer see the slide within the light box in my modified version. When clicking "OK", the light box is closing for me, and returning to the initial slide. Are you wanting to show a different slide?

Thanks!

Christine

James Brandwood

Hi Christine,

I believe we are having very different behaviour from Storyline. I have attached a story project that has screen recordings of both my, and your versions of the lightbox story when previewed on my computer.

I am wanting the lightbox to close and go to the introduction slide as the triggers suggest but as you will see from the sceen captures when the 'close light box' trigger is first all it does is close the lightbox.

Christine Hendrickson

Good morning James,

Thanks for the screen recordings. You're right, I'm not seeing the same thing, at all. When I look at the version I modified, I never see the other content after closing the light box, only the introduction. 

I did a quick screencast for this, so you can see the differences on my side. I apologize if I sound half-asleep - still early!

Thanks again, James!

Christine

James Brandwood

Hi Christine,

No need to apologise, I didn't notice any snoring in your recording so that is a plus. Besides at least you are only half-asleep, I have a 3 year old and an 18 month old who both slept terribly last night and I am pretty sure I am asleep.

I have compared my 'Light Box Close First' poject and your modified version and I can not see any differences between the two except for the one extra blank slide on mine that does nothing. I deleted the blank file and got the same result.

It's as if my copy of Storyline is processing the instructions/triggers given to it differently to yours (and probably everyone elses) even if the file was made on a different computer.

I really don't have a clue how to fix this unless there is option in settings that I have missed called "stop screwing with James' day" but I just don't think I'm that lucky.

Christine Hendrickson

Good morning James,

Babies are wonderful, just not so great for sleep

This is really strange. I'm not sure why it would behave differently on your machine. I took a look a the original file that you posted and realized what I may have failed to mention earlier. The order of the triggers on the light box slide may be the issue. 

Here's what I did:

Let me know if this makes a difference for you. I forgot to mention earlier that the order of the triggers is pretty important, if the first trigger is to show the other slide, that's what will be called first. However, if the first trigger is to close the lightbox, it should work properly.

Hope you have a great day!

Christine

James Brandwood

Hi Christine,

It was the fact that neither order of the triggers (having the close or jump to first) wasn't getting the correct response that led me to making my original post.

I attached two files, one with the 'jump to' first and one with the 'close' first at the start of this forum to show that neither was working correctly. In your previous posts you were referring to the file with the 'close lightbox' first and the 'jump to' trigger second, which should be the correct order but would just close the lightbox and not jump.

In your last post you have switched to looking at the other file I attached where the jump to is first and causes the slide to be opened in the lightbox - which is what you would expect.

I think we are still stuck at looking at two machine doing different things despite having the same software installed. Is there any reason this might be happening?

James Brandwood

Hi Christine,

So not quite the same version.

This may be the result of previous issues with Storyline limiting the number of screen recordings you can link on one slide. I had assumed you guys would have the same slightly newer update 1. I was dealing with Peter Anderson on that one but I wouldn't expect something that prevents flash crashing would effect lightboxes.

Christine Hendrickson

Good morning James,

Yes, the version I have on this laptop is just for my own testing and examples. However, if this is something that's occurring with the later update (that you're using), it would be best to let our tech and QA team know about it. Would you mind submitting this information in a support case, so we can document it and investigate the issue?

I'd really like to see how this turns out. If possible, please share the case information with me (you can do so here, or in a private message) so I can follow the progress.

Thanks very much, James.

I hope you have a great day!

Christine