Line spacing problem in import / export process

We create courses with quite big text masses that are translated into several languages. In the export - import process line spacing grows (although the setting remains the same) thus destroying the page layout. Spacing in identical text fields (e.g. with setting 1) between original text and imported text is different although the setting is the same. This instability occurs also with other line spacing settings (according to my tests extra space is added above the line, space below the line remains original). Is there other way to solve this instability but to create new text elements on each slide into which you copy the imported text? Is this on your repair list - in the near future, will it be possible to adjust line spacing accurately with desimals or with some other way?

23 Replies
Brett Rockwood

Juha, line spacing is just one of several limitations in the current version of Storyline. I've seen lots of strange behavior when importing slides from Powerpoint that use custom line spacing. Sometimes they actually come into SL with what looks to be the proper spacing set in PPT, e.g. 1.25 line spacing. Other times—and this can happen in the same SL file—the line spacing will be reset to match one of SL built-in amounts, i.e., 1, 1.5, 2, etc. I've had the same issue with paragraph spacing being inconsistent on importing from PPT.

Some of the other typographic limitations to be aware of and that bug me on a regular basis are: no way to set tabs, unable to customize bullets or numbering, not all characters work (e.g. no em dash — or en dash –), no "smart" quote marks, no table functions, no hyphenation, no paragraph or character styles.

My suggestion is to submit a feature request to get your desire heard. I'm hoping—no praying—that some of these key features make it into the next update to the program.

Ashley Terwilliger

Hi Juha and welcome to Heroes!

Brett is correct that importing from Powerpoint is not a one to one conversion, but it sounds like you're doing the translation import/export of a Word document for Storyline? Can you confirm this set up? I've heard of a recent case where there is occurred - but it seemed font specific. What font set  up are you using? 

Ashley Terwilliger

Hi Juha,

Try to change the font from Arial Unicode to the Articulate font - the Arial unicode font was the exact one that was mentioned in a previous case that has been shared with our QA team. I'll add this thread to that report as well, just so that our team is aware of other users impacted by it and so that if there are any additional updates I can share them here with you. 

Leslie McKerchie

Thanks for the update Fabio! We had an issue with translation formatting in Storyline 2 as well that was corrected in Update 5. Please be sure that you are utilizing the latest update to Storyline 2, which is Update 6. If you are still having difficulty, please reach out to our team here and share your .story file so that we can take a look.

Cynthia Manika

...so the issue has not completely fixed or am I missing setting some default for a project?  I have the same issue with copy and paste - I make sure ALL formatting is cleared before I copy and when I paste into a text box or notes that previously was manually formatted - both object item and/or selecting text - and it jumps to 6pt or 8pt after (and sometimes also before) and multiple line either 1.05 or 1.08 - it depends on which project file I am working in as I have 3-7 projects going at a time in different phases.  So after EVERY paste I must re-select and format the paragraph..0..0..single.  I tried formatting placeholders in the master - can't select notes area in master.. help this is terribly time consuming - and I can't get the clients to like the default spacing.  (note: copying from an email, word, txt file, or PowerPoint seems to deliver the same results - only variable is what template I am using for creation - one of my design or company gave me which was probably purchased in India - and those wack out font size, font face besides line spacing when pasting - fun times)

Ashley Terwilliger

Hi Cynthia,

I don't see if Fabio shared a file with us, but if you'd like us to take a look we're happy to. The issue detailed originally in this thread was with Storyline 1 and that issue remains with our QA team for additional review. If you're using Storyline 2, did you check that you're on the latest update -now Update 7 as Leslie mentioned as there was a translation formatting fix?

Ashley Terwilliger

Hi Cynthia,

There isn't a default Notes setting but again, if you were copying/pasting text it that already had formatting that would be carried over regardless of defaults - as that would just be a set up for new text.

Are you using Storyline 1? You can check which update and version you're on by going to the Help tab -> About Articulate Storyline and you'll see it documented there. 

Cynthia Manika

No I have Storyline 2, latest patch, it will NOT keep paragraph setting.  it doesn't matter if I am taking text from Word, an email or PowerPoint -  WHEN I am replacing text in Notes - example - I get narration edits - current text is single space, no space before or after - I copy the new text, highlight what needs replacement - paste and then I have to select everything and change paragraph spacing back to 0 before 0 after and single line spacing.  I have tried to format the text before I copy; remove all formatting before I copy; save as a TXT file and copy from there - NOTHING saves me the step of redoing paragraph formatting each and every time after pasting.  I already had issues with importing so I stopped doing that a while ago as it took longer to go to every slide and look at everything and fix more than just the desired changes.

additional issues when using a template created in another country, but I expected some wackiness with different language versions.  But having these issues with templates I created is driving me nuts.  thanks

Ashley Terwilliger

Hi Cynthia,

Could you share one of these templates with us so that we could see the behavior your experiencing? As I mentioned it was something reported in Storyline 1, but I don't see anything reported for Storyline 2 so far, so we'd want to take a look at what you've got set up. You can share it here in the forums or send it along to our support team here. 

Daniel Mensch

Hi, I realise that this is an old thread, but the headline relates quite well the issue we are experiencing.

I am using Storyline 360 with latest updates applied, and using the client's custom fonts.  When importing a translated text using the Word option, all instances where Line Space After has been set to value other than zero gets reset to zero.   

See the attached screen shots. 

The spacing in this example is originally set up as Line Spacing Exactly 18pts, and 18pts After (Image 1:
Impage 2: In the Reference column in the Word table, the points After have show as 0 pts and Exactly 13.5 points. 

 

The spacing in this example is originally set up as Line Spacing Exactly 18pts, and 18pts After (Image 1).  In the referent column in the Word table (image 2) the points After show as 0 pts and Exactly 13.5 points. The righthand column text shows the same. (Image 3)

Importing from this table without changing anything results in the Line Spacing After being set to 0 pts (image 4.)  Interestingly, the setting of Exactly 18 pts remains intact, despite showing up as 13.5 pts in the Word table.

There are several other examples with differnt spacing settings, and in all cases, the translation process sets the Spacing After setting to 0 pts (whit the Exactly setting intact.)

We're about to translate 35 languages - translations in progress and importing process will need to start soon - so it will be very important to solve this if we are going to avoid many many hours of manual post-import adjustments. 

Thanks!

Cynthia Manika

FYI - still a huge issue I experience on a constant basis - I have given up asking for help as I get newer versions as this has not be resolved even if using only English but open on another computer to make a quick edit - fun times.

You will also need to change font to Arial unicode (their suggestion) or expect lockups and not being able to publish to Word to proof and many many other issues - changing font does not resolve everything - but slows down some of the really nasty issues. SAVE OFTEN

...also, when not the entire course - but anytime I bring from Word, I only copy then choose paste option (Keep Text Only) - and no speed key for that - each slide object one at a time.

When I bring in with import translations and have issues - then I use the format painter and go slide to slide to resolve. Example, It took many hours to clean up 17 languages in a 280 slide course and have it Save successfully - but at least I had the sense to put carpal tunnel wrist wraps on first.

Good luck my friend - I look forward to their resolution to you.

Dave Bull

Not sure that this will help but i've been imported a PPTX file into SL360 and the paragraph spacing is very different that it is displayed in PP.

They are both have Spacing set at 0 Before and After and Line Spacing to Single...

I just change the Line Spacing to Multiple at 0.7 and it looks fine...bit of a pain in the b*m but what the heck!

Ashley Terwilliger

Hi Dave,

Are you having to adjust this to account for issues with the translation export in Storyline, or when importing Powerpoint slides into Storyline? If the latter it sounds like a different issue, so I'd want to know a bit more about your set up and what you're running into so that I can test it out! 

If you also want to share a sample .ppt or .story file here with me, I can use that to test as well!