11 Replies
Barry Galvin

Hi chaps,

Yes I inserted a web object and chose a folder which does have the index.htm named file within it, and did the Test Link and that worked fine. When I publish however, and view the slide, the web object doesn't actually show up, so is just a white blank space. It works fine if I link to the file online, but just not locally.


The WebObjects folder is created during publishing, but my decision folder name is changed to a random character/number folder name, but still holds the index.htm file within it (please see below).

So basically, I'm doing the right things I think, but not getting the right results :(

Thanks so much for you responses so far.

Russell Still

Just a guess, but it may be the dynamic directory naming that is getting you. Since you compute the directory name at run time, the embedded structure probably only contains the hardcoded (i.e. at "compile" time) folder name. Have you tried it using a fixed name for that directory?

I'm not sure how SL handles this internally, but it's also possible that only the index.html is getting embedded (i.e., not the contents of the entire directory/subdirectory structure). Since it is embedded code (and not an online location) there might be no ability to address other files. Just a hunch...

Denis Pouliot

Hi Gerry,

In your exchange with Barry you mentionned an index file. Maybe you can help me find the solution to my problem.

I was working on a presentation with Storyline, I tought I could import some Engage interactions that I did a while back. I couldn't find the .intr files but I did have the published files. In Jeanette screencast "How to insert a local web object in Presenter" she mentionned that the file to import had to be an "index.html" file.

I do not have an index file or folder. Instead I have the following on my hard drive:

engage_content folder

engage.html

engage.swf

I tried to create my own index file, I renamed the files and I search all over in the community for "Missing index.html" file + engage without success.

Could you or anyone else help me out?

Merci

Denis Pouliot

On the screencast chatter, I posted my problem to Jeanette. Here is what she suggested.

in your published Engage output, try changing the engage.html file to index.html. Then insert that as your web object in your Storyline project. If you need additional help, I'd suggest posting in the Storyline forum.

As suggested, I renamed "engage.html to index.htm" and the folder "engage_content to index_content". I left the "engage.swf" file as is. I used a Chrome browser to open the html file

It opens up in a blank window with the name of the path which lead to my "engage.hlm" file.

What am I doing wrong ?

Denis

Ashley Terwilliger-Pollard

Hi Elisha, 

Are you working with Web objects as Denis was? If so, there are a few reasons documented here on why they may not play as expected. Also, web objects need to use  full (absolute) URLs when being added to your content, and not relative urls. 

A possible workaround for using relative URLs can be found in the forums. This method may work for your scenario, but please note that we don't officially support it.