Links and triggers keep breaking

Feb 09, 2017

We've launched a course and for several mods, made in Storyline 2, triggers that worked fine in the pilot are now broken. For example, in the attachment (un-fixed), slide 2.3, this entire mod was fine in the pilot. I made a few edits to slides OTHER than 2.3 in the file, re-published and now the doc that is supposed to open by clicking the button on 2.3 doesn't work. I went back into the Storyline file and the trigger is perfectly fine. So I had to remove the trigger, re-made it the exact same way, published and now it's ok. This has happened several times with several mods.

This caused a real headache in translated versions of this same course (11 individual storyline mods) where all of the hyperlinks broke, even the ones where the text of the link & the link itself were not translated. Again, the triggers all looked fine but I had to redo them all. 

Ideas as to why this is happening?

8 Replies
Mr C

Hi Margaret

A different way to look at this is you could use the Resource section of the Storyline Player

Instead of hyperlinking the document and hoping it works, upload the document (file not url) as a Resource in the Storyline Player

You can provide instructions on a slide as to when you want the learner to read the document

Regards

Ashley Terwilliger-Pollard

Hi Margaret,

Two other thoughts in addition to what Mr. C shared are to ensure you're working on and linking to local project files as working off a network drive is known to cause errors and odd behavior. You'll see more details about that there.

Also, when you're testing the published output are you seeing an error message or the document just doesn't open? Are you able to confirm that you're testing it by uploading to the intended publish environment or were you looking at testing it locally? Testing the published output locally can cause you to encounter security restrictions and other unexpected behavior. 

margaret richards

Ashley, I am not on a network drive, learned that lesson several projects
ago! It says the document doesn't exist when clicking. This is in the
published environment (Moodle). Again, it published fine the first time
(several times, actually), it's just for some reason with my last round of
updates the triggers to links and URLs are breaking.

Mr. C, that's a good point about using Resources in the future but I ca't
go back and redo all of my modules now. Also, I really shouldn't have to do
this -- I'm using the triggers correctly so I really just want to know if
there's some known bug or other issue. It's much easier for users to skip
or miss activities, links, resources, etc when they are in the resources
tab rather than when they are staring at them on screen.

Thanks to both!

Ashley Terwilliger-Pollard

Hi Margaret,

I always like to start with that - you'd be surprised how often that's the case. 

I see your file as linked and I'm curious if all your files are hosted in a Dropbox set up? Although Dropbox is a local install, it's ultimately connected back to the Dropbox servers. I know lots of other users have implemented successful links with Dropbox, but I'd test it outside of that to double check - especially if it works initially and then after you close out the project the link is broken. That's when I suspect some type of latency between the original link and the file stored in Dropbox could occur. 

Also for Mr C's recommendation - you can add resources to the course player, but then link them onto the slide as shown here. Just as a way forward it may be good to take a look at that set up. 

margaret richards

Many of the individual docs (.docx, .pdf) are in Dropbox but none of the Storyline files are. Could it be that?? Again it worked fine through several iterations. I assumed that once the docs were linked they were 'attached' to the Storyline file, rather than being retrieved from from the folder during publishing.

What about URLs? Some were linked to objects (buttons), some were text links but when I imported the translation, even links whose linked text didn't change stopped working; like the documents, the triggers looked fine. (I don't have any of these files, I fixed them all).

Ashley Terwilliger-Pollard

Hi Margaret,

In Storyline 1 they were pulled into the .story file, and there is a known issue with our QA team right now where that's not happening in Storyline 2. So the connection to a network document could be what is still tripping this up within your files. I'd recommend using local files whenever possible just to help prevent that odd behavior (even once the issue mentioned is resolved) but I'll also include this form discussion in the report with our team so that we can updat eyou here once there is any additional info. 

URLs are handled a bit differently than file links, so the links to a URL should still be fine and working. The translation element there may be where things went off the rails if there was a change to how the formatting or overall text in that link. Were you able to relink those items after importing the translation document back in?

This discussion is closed. You can start a new discussion or contact Articulate Support.