LMS Issues with Completion

Hi Heroes,

I wanted to start a discussion about if other Storyline users are experiencing issues with LMS management tracking eLearning completion.

Our company has multiple offices and our eLearnings are accessed through our LMS system. Currently there are 2 ways to access the LMS, through the server and through VPN (remote access).

We've had users (minority of the population) report that upon completion of an eLearning that it did not mark as complete in their transcript. Most of our users however had no issues whatsoever. Amongst the users who report an issue, they are both local and remote.

We tried editing the Reporting and Tracking feature to Passed/Complete, Passed/Failed, Completed/Incomplete all with the same results.

Does anybody have similar issues? Anyone with this issue have a resolution? I'd love to hear your responses.

Thank you,

Ron

2 Replies
Ashley Terwilliger-Pollard

Hi Ron,

Do you know if it was a particular internet browser that they were using? You'll want to ensure that all the users are up to date with the viewing requirements indicated here. Do you have the resume enabled, if so there is a known issue where they may be marked as incomplete if the user finishes the course after resuming it. 

You'll also want to confirm that they've met the completion requirement you've set up (whether it's a number of slides or a results slide) and you may also want to review this blog post on troubleshooting common LMS issues. 

Mike Kovatch

I am having a similar problem.  I have a Quizmaker quiz running as a standalone assessment.   When I complete the quiz, it provides a report page with the SCORE and Passed/Failed.  When I click the "Finish" button on the quiz, the score is written to my LMS status page.  However, if I FAIL the quiz, the cmi.exit value is always "suspend".  When I go to retake the quiz, the Quizmaker quiz opens in a new window and the first question is always, "Do you want to continue where you left off?".  I have to choose "NO" to restart the quiz.  However, no matter how many times I "retake" the quiz, the attempt counter is always ONE! 

I posted a question about this on the SCORM Cloud website and they said that the attempt counter will never increment if the cmi.exit value is 'suspend'. 

I was able to get the "normal" status for the cmi.exit by ediitng the Configuration.js (var DEFAULT_EXIT_TYPE = EXIT_TYPE_FINISH file in the /lms directory.  The only problem now is that if I WANT to suspend my 50 question quiz (e.g., complete 25 questions, then take a break and resume quiz at a later time), the 2nd (suspended) attempt gets a cmi.exit of 'normal', and increments my attempt counter when it should not be incremented.

Does anybody know a different way to get the attempt counter to increment properly?  The way I THINK it should work, if you complete a quiz with either a Pass or Fail score, the cmi.exit value should be 'normal'.  If you close the quiz without answering all of the questions, the cmi.exit value should be 'suspend'. 

What is wrong with my logic???