Master slide video looping issue

Have added a video of 11 seconds in the Master slide of storyline 2 (update 13) and made it looping. Now the video works smoothly when I am viewing the course, it loops after every 11 seconds and plays from the 1st frame to the last frame exactly the way it should loop, but once I switch on to another browser tab and come back to my course the video in the background does not play properly. The video gets looped but not from the 1st to last frame, it gets looped on some other frames.

Also, if we switch the browser tab before the video starts looping then this issue is not replicated, it gets produced once the video starts looping.

Any help/solution would be really appreciated.

Regards,

Amey

5 Replies
Crystal Horn

Hi Amey! I'm seeing consistent looping on my end in Internet Explorer (Flash output) and Google Chrome (HTML5 output). I tested with a slide that used a video placed directly on the slide, and with a second slide that uses a slide master layout with looping video. Here's my link.

With your permission, I'd like to take a look at your .story file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Amey Waingankar

Dear Crystal,

I checked your link and the video is not looping consistently. I was able to replicate the same issue. Here is the screen recording for the issue.

My files has few differences i.e. the video has a soft sound as it is executing in the background of each screen. Also, the screens have audio (mp3) files and thus both are played at the same time. 

I have shared my source file privately as well for your troubleshooting.

Regards,

Amey

Crystal Horn

Thanks for the video, Amey! I was able to spot the difference:

  • If you navigate away from the video before it finishes the first time, the subsequent loops start from the point when you navigated away.
  • If you let the video play at least once and then navigate away, the video will start over when you return, and subsequent loops will start from the beginning.

I'm documenting this bug for Storyline 2 so we can track the customer impact.