Matching drag and drop not working in mobile

I have a matching drag and drop with 9 items. On the iPad the scroll bars do not appear. I read about 2 finger scrolling and that works intermittently. It is very difficult to scroll back and forth. Also the submit button does not do anything (i am using v.5) The last problem is that the "answers" and the "questions" do not always line up. the question highlights when the answer appears to be lined up, but when released the answer jumps back to original position (or another position).

These problems only occurr on iPads. It works fine on PC in chrome, firefox and IE9

The lesson is on an LMS and is in a popup not an iFrame.

Thanks

5 Replies
Ashley Terwilliger-Pollard

Hi Ed,

The two finger scroll is something that our team is aware of in terms of users preferring a one finger scroll - so if you'd like to see the behavior changed, I'd ask for you to share those thoughts in the form of a feature request here. 

As far as the submit button and how the answers are not lining up, I'll want to take a look at your .story file to see how it's behaving, even just that one slide would work. You can attach it here using the paperclip icon. 

Ashley Terwilliger-Pollard

Hi Ed,

Thanks for sending this along. I tested it out on my iPad, and couldn't get it to scroll - iPad mini, probably not enough room on the side for the two fingers. So I had a colleague test on her iPad 2, and she saw the same behavior as you described with the misalignment of objects and then you won't be able to submit it because they don't match up. I reported this to our QA team for additional review, and in the meantime, I'd recommend breaking the matching drag and drop into smaller groupings - it looks like about 6 fit before you have to scroll. 

ed dorociak

Ashley,

Thanks for your help with this matter. I am wondering if I break it up into smaller groups, will they match properly, and will the submit button work. The way it is now, on a computer if you hit submit prior to matching all of the choices you get a popup message "you must complete the question before submitting" but I never got that message on the iPad. Is this an issue with the submit button, or is it because of the misalignment of the objects. I would hate to change the course, republish and upload, and still have the same problem with the iPad.

Thanks for your help with this.

Ashley Terwilliger-Pollard

Hi Ed,

I actually received the "invalid answer" message indicating I hadn't provided an answer yet to the question. I had a few other colleagues test this as I mentioned to see the alignment behavior, and they all saw the invalid answer message as well. What iPad are you using and what iOS? We were testing on an iPad 2 and iPad mini, both with iOS7. 

The first 6 I could see matched properly - and my colleague reported that when able to scroll and try to match the lower ones, that's when the alignment went haywire. So with that in mind, you should be good with a smaller matching interaction - just keep it out of a scrolling panel for now.