Minus symbol not showing up?

Hi,

I've been trying to create a project whereby the users are able to key in symbols into Input boxes to create math expression.

Since keyboards do not have immediate access to math symbols like minus and divide symbols, I tried to create triggers that would replace certain symbols with the corresponding math symbols to act as a shortcut.



For example, this trigger will replace the dash symbol into a minus symbol when users enter a dash symbol into the input box.

This trigger works fine for both division and multiplication symbols, however just wouldn't work for the minus symbol. After keying in a dash symbol, it would completely leave the input box blank. I've checked it with a variable reference, and the minus sign is definitely there but its just not showing up in the input box.

I've tried many roundabout ways, creating a MINUS variable with a minus symbol as its default value and assigning the trigger it with the MINUS variable instead; as well as assigning other symbols that resemble a minus symbol to the trigger.

But none of these seemed to work, so I figured it was some sort of bug.

Does anyone know any way around this problem with the minus symbol, or even know how to tackle this?

Thanks in advance! 

9 Replies
Jia Lin Lee

Hi Wendy,

I've just tried it and it's not really what I'm looking for, unfortunately.

I'm mainly trying to display the symbol and not really doing any calculations with the variable. With the way how the Numeric-entry field works, I couldn't replace the hyphens with minus symbols.

Thank you though!

Ben McKenna

Hi Jia,

That's bizarre - I've just tried your trigger setup on a standard text entry box, and I can definitely see the  hyphen being replaced with a minus symbol on my end. Just for your reference I'm using an English (US) keyboard and the input field is set to use Open Sans font.

And just since I'm curious, does the dash symbol not function identically to the minus symbol? I know some languages can be quite strict, but I would have imagined an expression using a dash should calculate perfectly fine.

Jia Lin Lee

Hi Ben,

I'm using English (US) keyboard as well, but using Sassoon Primary font- which is a downloaded font. Maybe the new text-rendering engine has an issue with symbols, this trigger worked perfectly fine for minus symbols before I updated.

Maybe you could try it out with a downloaded font? The minus symbols I'm using are U+2012, U+2013, and U+2212 in Unicode.

Yes, the dash symbol does function identically to the minus symbols. However, because the project I'm working on is for an educational publisher; They're pretty strict on they fonts and symbols used.

Ben McKenna

Hmm, I managed to come across the issue with one of the symbols disappearing (U+2013) when I changed the font to Aller Light (a custom font I had installed).

Here's a published test file so you can see if the results are the same on your end:
https://360.articulate.com/review/content/d8eba932-7876-4b5a-a690-bd013537dc87/review

The issue with the missing symbol seemed to be fixed when I changed the textboxes back to Arial. Is it possible some/all of the dash characters are missing from the Sassoon Primary font you're using?

Jia Lin Lee

Unfortunately, I need all symbols to be in Sassoon Primary to standardise the style.

The only character missing from Sassoon Primary seems to be U+2012, while U+2013 and U+2212 are definitely there.




Despite using these two available characters, they still clear the inbox for me.

Strangely, even though U+2012 isn't available in Sassoon Primary- it replaces the symbol but in a different font. Replaced font type depends on the default font type of your device, take note that it might look similar to Sassoon Primary Medium on IOS but the symbol is not long enough to look similar to a minus symbol.

Here's a published file of what's happening on my end:

https://360.articulate.com/review/content/713acb9e-ffab-4b2b-81ec-bba3dfbefef0/review

I've also attached the working file below if you need it.

Alyssa Gomez

Hi Jia,

Thanks so much for sharing the link and your file with me. I'm definitely seeing the issue when I tested your file in Articulate Review.

Would you mind also sharing the Sassoon Primary font installer file with me? I'd like to share all of this with our Support Engineers to get their insight on what's going on here.

Jia Lin Lee

Hi Alyssa,

I would love to share the font installer with you, but Sassoon Primary is a font purchased by the company I'm working under. Permission was granted for sharing the font, but they would like it to be formalized just in case.

Could I have your email so that I can send the font installer and the formalized note to?

Thank you!