Mobile App no longer functioning with Litmos posted content

I uploaded an Articulate Storyline module to Litmos on or about April 30, 2013.  The course was published through Storyline using TinCan and included HTML5 and instructions to use the Articulate app and allow downloading for offline viewing.

As this was my first attempt at publishing in this manner, I and others tested it inside and out to make sure that the app worked, downloading worked and that results were being pushed back to Litmos.  Everything worked great!

This is a VERY SIMPLE Storyline module with no interactions and a 3 question quiz at the end.

Somewhere between then and now, something has changed and I'm not sure what, nor where to start looking.  With updates to Litmos, iOS and Articulate Mobile, it's going to be like looking for a needle in a haystack.

One thing I KNOW - the content that used to work on the Articulate Mobile app has NOT been updated even though Storyline has had a software update since then.  i still have the original .story file and the .zip package that was uploaded (attached)  

I can access the content on a desktop computer through Litmos as a learner.  It appears to recognize that I am returning as it shows that the module is in progress and asks if I want to resume where I last left off.   When I try to access the content on my iPad, it launches the Articulate Mobile app and begins to play the content.  There is a dialogue box that states UNABLE TO CONNECT TO THE SERVER.  Please verify that your device can connect to the internet.  CLOSE or RETRY.

The entire first slide plays, with it's narration, but I cannot advance the presentation.  Selecting RETRY has no results and selecting CLOSE returns me tot he Library where I see thumbnails of all of the modules that I have attempted to view.

When I attempt to select one of the modules from my library, I get an error message that states:  CANNOT ACCESS CONTENT.  Articulate Mobile Player cannot access this content.  LEARN MORE (goes to Articulate Support topic "Cannot Access Content" Error when launching Articulate Storyline Content in the Articulate Mobile Player") or OK.

Based upon the information on the Articulate support page, my best guess is that there has been some change to the Litmos private content authorization for TinCan, because I am POSITIVE that this worked properly at some point prior to now.  (Although the possibility of my imagining this is not completely off the radar!)

I will be cross posting this in the Litmos forums to try to get this resolved ASAP, knowing that a solution could come from either location.

6 Replies
Ashley Terwilliger

Hi Janet, 

Storyline publishes to Tin Can API version 0.9, and it's possible that Litmos has updated their Tin Can API which may be causing the problem. From what I'm hearing, we are planning to support 1.0, but we currently aren't able to share a time frame for when it will be available. You may want to share your thoughts on needing support for 1.0 with our development team by submitting a  Feature request if you find out that Litmos has done this update. 

Janet Cecchettini

I have contacted Litmos to inquire as to the version of the Tin Can API they are using.....

In the meantime, does publishing to Tin Can API v 0.9 also apply to the new Presenter Studio '13?  

I was part of the beta group and was very excited to see the product officially hit the market.

Incompatibility (whatever the cause) is going to be an ongoing problem with Storyline/Studio/Litmos/iOs7/Articulate Mobile Player, etc......

Janet Cecchettini

Litmos confirms that they are running Tin Can v 0.95 and hope to support v 1.0 in the near future.

I don't know enough about the API to understand what changes have been made, but as product updates are released, is the Tin Can version spec listed?  With the Articulate products, users can choose whether or not to upgrade their version if incompatibility is suspected, or can test for compatibility.  

With SaS, like Litmos and other cloud-based services, they incorporate the upgrade into the service and you don't know that things have been changed until the warning bells sound!  I have contacted Litmos again to inquire if the use of Tin Can v 0.95 is an upgrade since April 30 when I published the content and it functioned properly.

I'll keep posting updates as I imagine I am not the only one experiencing this.