60 Replies
Richard Fouchaux

Hi,

I just installed the latest updates this morning, published afresh, and I still have this issue as well. The glossary does not appear either. The Web Inspector reveals the content is in a <li> element with classNames including 'tab-glossary' and 'hidden'. When I remove 'hidden' it appears and works. It's not clear why the logo (pure white on transparent bg) is hidden as manipulating the classNames has no positive effect and I don't see a hidden parent; the background-image:url (6LhgM5pP3qc.png) loads properly when I paste the path directly into the browser.

Here's the HTML as loaded:
Logo:

<div style="background-image:url(/D:/Documents/My%20Articulate%20Projects/HR101/OUTPUT/Human%20Rights%20101%203rd%20ed.%20(2019)%20-%20Storyline%20output/mobile/6LhgM5pP3qc.png);" data-reactid=".0.0.3.0.0.0" class="logo cs-logo inflexible"></div>

Glossary:

<li class="tab cs-tabs tab-glossary hidden " role="button" tabindex="-1" data-reactid=".0.0.3.0.0.2.0.0:$1">
<button class="tabs-trigger cs-inner-button" id="tab-glossary" aria-selected="false" data-reactid=".0.0.3.0.0.2.0.0:$1.0">
<span data-reactid=".0.0.3.0.0.2.0.0:$1.0.0">Glossary</span>
<span class="accessibility" data-reactid=".0.0.3.0.0.2.0.0:$1.0.1">, inactive</span>
</button>
</li>

I'm publishing HTML5 only and I have the same result in all browsers (i.e., the above generated code is the problem).

I've seen both work on this same system, but, this project, mostly not. I've been looking forward to putting this folder on a web server later this afternoon... maybe that will influence something, but I doubt it given AS360 appears to generate the tab code 'hidden' from the start.

I do know how to write JavaScript to remove the unwanted className, and place it on a slide or master slide, but I don't relish doing anything like that.

I'm generally very pleased with AS360, eagerly await updates and install them on at least one machine asa-available, even during development. The coming and going of these items has been quite disconcerting.

Leslie McKerchie

Hi Brooke,

Thanks for reaching out and letting us know that you're running into an issue with your logo as well. I appreciate you sharing that you're following our recommendation shared above to have your menu enabled as well.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Richard Fouchaux

I'm still having this trouble. v3.28.18944.0 has been the first update I've regretted applying upon arrival. I'm also having issues with audio: a "hiccup" repeating the first word of a narration as it starts. The file plays perfectly from right-click or Options->Play button and when published. A slide that did this for an entire session was fine next session, but I soon found another slide exhibiting the same behavior. And when I preview a layer, instead of stopping at the end it returns to the base layer and runs through it silently until I click somewhere to stop it... then the layer I'm working on reappears. This version frequently closes while publishing, or reports "Not responding". This is happening on both my Windows 10 workstations. One has 16G RAM, the other 8.

Richard Fouchaux

Here's what I've learned. When I view the DOM in Web Inspector I see the DIV appears to have been assigned an absolute URL on my hard drive:

<div class="logo inflexible cs-logo" style="background-image:url(/D:/Documents/My%20Articulate%20Projects/HR101/OUTPUT/Human%20Rights%20101%203rd%20ed.%20(2019)%20-%20Storyline%20output/mobile/5tBcyUJyyfy.png);" data-reactid=".0.0.3.0.0.0"></div>

When I remove the absolute path to my local folder:

<div class="logo inflexible cs-logo" style="background-image:url(mobile/5tBcyUJyyfy.png);" data-reactid=".0.0.3.0.0.0"></div>

...the logo appears.

I can't find the div in story or story_html5.html and I haven't investigated further. It would be possible to write a script to fix it on page load, and maybe I will, if you don't beat me to it. :-)

 

Richard Fouchaux

It's in ..\html5\lib\scripts\app.min.js. If you search for 'cs-logo', immediately after you'll find (between two commas):

style:{backgroundImage:"url("+this.logoUrl()+")"}})

Very carefully replace everything inside the outermost pair of double-quotes with

url(mobile/YOUR-LOGO-FILENAME.png)

Mine now looks like this:
style:{backgroundImage:"url(mobile/5tBcyUJyyfy.png)"}})
and my logo is appearing.

I used Storyline's filename, which I found in the way I mentioned earlier (Web Inspector), but you could drop the file into the 'mobile' folder and use your own name.

This needs to be repeated every time you publish, and if you use another filename in a SCORM course don't forget to update the manifest to include it. It's not as bad as it might sound... I use Notepad++ for this sort of thing because the files and snippets persist between sessions, and it tells you whenever the one loaded differs from the one on the disk. I'll use this workaround until an update fixes it.

Mitchell Gray

I was having a similar issue today with a course where the logo was showing up, but then stopped showing up after I changed the title.

After some experimentation, I discovered that the length of title/folder names for the published project can affect whether or not the image is showing up....for whatever reason. 

 

For instance if the path to your project is:

C:\User\StorylineUser\Desktop\ShortOutputName\story.html

it should work fine as opposed to

C:\User\StorylineUser\Desktop\Extra Long Output Name with Text - Storyline output\story.html

the logo won't show up. (The client for my project wanted a longer name than even that, so I'm not sure what the cutoff might be, for characters, certainly less than 260, my full path was 108)

You can try to change the name of the folder your project outputs to and see if that fixes it. Also, know that if you send the files to a .zip file and use them on an LMS the length of the folder name the project was published to does NOT affect whether or not that logo will show up (something I also just tested).

Hope that helps,

Mitch