Mouse click & drag functionality stopped working

The click & drag functionality of my mouse and pad have suddenly stopped working for no apparent reason in the middle of a session. It's not the mouse or the computer, only within SL2. I can click to open something and the cursor changes state on an icon, but I cannot drag an item or resize it. I've done the usual of shutting everything down and rebooting, as well as looking at an old project and opening a new one. Same problem. Can anyone help? Is there some basic control for mouse functionality I've clicked by mistake?! It's quite urgent (always is!). Thanks, Lynn

27 Replies
Lynn Mathew

Sadly the same problem recurred on opening up the computer this morning. I have followed everything on the guides, including restoring the computer to a previous state and starting the process all over again. I don't understand how I got it to work last night, but now it wont. Rather at my wits end to know what to try next...!

Lynn Mathew

Hi,

It has literally just started working again, but I don't understand how. I followed all the steps in your link right through and it did not work, so I came out for a while. However when I opened it up again half an hour ago it was working! So, the problem seems to have righted itself but I am not sure why. So, thank you for replying again, and fingers crossed everything is okay. I'm somewhat scared to switch the computer off! Thanks again Lynn,

Ashley Terwilliger

Ok - so you mentioned you read through the steps about working locally. Was the file saved and being opened from your local drive? If it wasn't, and you just moved it there after reading those steps there may still be issues within the file. I'd suggest importing it into a new file to resolve any lingering issues - and also testing the behavior in a brand new file that you've worked on exclusively from your local drive. If a brand new file exhibits the same behavior, please go through the entire repair steps I just shared and let us know how it behaves after that. 

Lynn Mathew

It wont allow me to take a screencast! The recording box appears but the whole storyline window disappears revealing my desktop. When I press record it records the desktop, then on closing, SL reappears. I have uninstalled  & reinstalled 4 times today & reinstalled .NET framework4 and Flash twice, rebooting at every stage. Yesterday I took the laptop back to an earlier stage when I knew everything was okay. The programme did suddenly start working again on one of these occasions, but not immediately after reinstallation, only after a gap when I left it to do something else. It is the same problem each time, the click and drag functionality has been lost. When inserting a shape or text box, it only opens a minimum size box. I cannot then resize it or move it with either the mouse or the pad. I can, however move things by clicking on them and using the arrow keys on the keyboard, but not resize. This is also the case with a newly opened project working on the C drive.

I noticed that when it was working okay and I closed down the whole laptop (after closing the programme), on rebooting the laptop SL no longer worked. This happened twice, although originally it just happened after 10 minutes of not using the computer. Could something be happening on shutdown/reboot?

Ashley Terwilliger

Hi Lynn,

My apologies for not being clearer, you'd need to have another instance of Storyline (or Replay or another screen recording software) open to record your current instance of Storyline and the behavior you're seeing. 

It sounds like this issue may have some deeper issues connected with your computer, so I'd like to have you work with our support team here so that they can pull some more system information. Please let them know in the description the steps that you've already gone through in terms of repairing your install of Storyline. 

James Snider

This happened to me in Storyline 1 right after my organization updated to Windows 7. The first time I saved my project, it became corrupted and had the same symptoms you're describing. When I went back to a previous project version, the project worked normally from then on out. I noticed that the size of the corrupted project file was much smaller than the file that functioned properly. I had to recreate a few items, but I didn't have the issue return afterwards.

Lynn Mathew

Hi,

Thanks. I've looked at a saved version, but it exhibits the same behaviour. However, I think I saved it to the USB external by 'save as' from within SL, rather than close SL then copy the file (before I knew the problems!).

However, newly opened projects on the re-installed SL are also exhibiting this, so I can't even start from scratch which I'm prepared to do!

Ashley Terwilliger

Hi Lynn,

I just checked in on your support case and see that Cleo shared the following:

For troubleshooting purposes, I suggest that you try to use a USB wired mouse. See if this works and if it does, try to update the mouse driver of your other mouse.

If you continue to experience the same issue with a USB wired mouse, please follow carefully the troubleshooting steps in this article: http://www.articulate.com/support/storyline-2/unexpected-or-erratic-behavior-in-articulate-storyline-2

There is a big possibility that your Mouse driver is causing the mouse pointer to go haywire in Storyline, since it's working properly with your mouse pad. I strongly suggest that you try to update or downgrade your mouse driver. Try to visit the manufacturer's website to download the driver. 

Hope that helps and if you need anything further please feel free to let Cleo or I know. 

Lynn Mathew

Hi Ashley,

Thanks for following up. To be honest I'm on such a tight timescale with an enormous project that I've simply downloaded the programme on to another machine and started from scratch again. I've not had time to deal with the laptop, although the programme is amazingly working again. I did open my project once at an early stage from an external drive just to check it before I knew of the dangers, so I'm guessing that may have been the problem. I've also changed mouse just in case as the other one was a bit skittery. I haven't dared copying the old project over and trying it in case it gives problems. So I'm not sure if the problem has really been resolved as I'm using another machine. However, I'll need to deal with it and transfer back to the laptop shortly, so we'll see!

Regards, Lynn

Amy L.

This is the problem I am having. But I already tried different mice and had the same issues. The links in the instructions above don't really go to specific places. If it lets me, I could uninstall Storyline 2 from this machine and try installing on another. I just need to preserve SL1 on the other as well. That machine gets too hot, hence my desire to use this one. But I need mouse functionality ASAP, as I have a client waiting on deliverables.

Ashley Terwilliger

Hi Amy,

It looks like Christie and I were also helping you in this discussion - and if you've tried those steps as mentioned we'd want to have you work directly with our Support engineers.  storyline 1 and Storyline 2 can be installed on the same system, so you shouldn't run into any difficulty with that set up.