MP4 video will not show in Preview or publish of Storyline course

Aug 08, 2022

I added a MP4 video to a course, but when it previews or is published the 'slide' comes up blank. 

7 Replies
Maria Costa-Stienstra

Hi, Kerry.

Thank you for reaching out!

Can you reproduce this issue with a different video, or is it only happening to a specific one? 

If this only happens with a specific video, is it an mp4 file you're inserting from your computer? Can you share it through a support case so we can investigate?

Another option is to re-encode the video using a third-party tool, HandBrake, to see if the issue could be related to the original mp4 file:

Let me know if this works!

Kerry Saunders

Hello,
And thank you for the quick response. I have tried 2 videos received from the same source, the save day (both MP4 files) and have the same issue. However, I am able to load another MP4 file without issue. Unfortunately I am not able to send the file due to security restrictions, nor download ‘Handbrake’.

I tried to load the file to Replay and the audio doesn’t fully come Any other thoughts?

Thank you,
Kerry

Kerry Saunders

Hello,

I have more information that may assist with this issue.
When selecting the video, and selecting Preview in the upper left corner, the video plays.

[cid:image001.jpg@01D8AB3D.819F5FD0]

However, when I select 'Preview' or publish to Review 360, the slide only shows as a blank screen.
I opened and republished the MP4 in another software (Camtasia) and am having the same result.

Again, any assistance would help.

Thank you!

Kerry Saunders
Manager, Courseware Development
Client Operations and Performance Enablement

800.918.8924 ext. 27163
ksaunders@evicore.com

1575 Garden of the Gods Road, Suite 200
Colorado Springs, CO 80907

============================================================== CONFIDENTIALITY NOTICE: This e-mail transmission, and any documents, files or previous e-mail messages attached to it may contain confidential or protected health information subject to privacy regulations such as the Health Insurance Portability and Accountability Act of 1996 (HIPAA). This information is intended only for the use of the recipient(s) named above. If you are not the intended recipient, or a person responsible for delivering it to the intended recipient, you are hereby notified that any disclosure, copying, distribution or use of any of the information contained in or attached to this transmission is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply e-mail and destroy the original transmission and its attachments without saving them in any manner. ==============================================================

Jose Tansengco

Hello Kerry, 

Since you mentioned that another MP4 file worked without issue, this most likely means that the behavior may be occurring because of how your videos are being encoded. If you have access to a video editing tool, try re-encoding the problematic videos as what my colleague Maria suggested to see if this helps. You can also reach out to our support team by opening a case so we can take a look at your videos to see what's going on. NDAs can be provided if this will help you share your file with us. 

Jürgen Schoenemeyer

and again, if storyline don't understand an video format - no problem, but why there is no error message like "unkown video codec" while importing?

and please don't answer: make a feature request for showing helpful error messages

that was the answer at the end of a not really solved support ticket (import error xliff 2.0)

Jürgen

Paul DeHorn

I am experiencing the same problem, but I think I found a solution. I inserted an MP4 video and in preview and publish to Review 360 I only see a blank white screen.

I edited the video in Storyline, just trimmed a short 1 sec bit off the beginning and then saved. Now the video is visible in preview and when published.