Navigation issue

Hi there,

I have been trying to figure out a problem with navigation with a course I am developing and I am completely stumped.

I have attached a copy of the course for anyone interested in a challenge.

The behaviour is that when I look at a layer the first time all works great. But whenI come back to look at the same layer a second time, the course appears to hang (the menu works, but all buttons are ignored).

I am using my own buttons to navigate. I did test with a Player PREV button and when it is clicked, it dissears. I have left that in for you to see.

There is a lot going on here, so I will help by providing steps for a specific testing path (although all similar routines fail in the same way).

  1. Close the intro box
  2. Drag the selector onto the Senior BA character
  3. check a capability checkmark from the blue rectangle to review that competency
  4. Click back to return to Capability selector
  5. Repeat until all are selected
  6. Once they are all selected, select PREV chevron
  7. From the line-up select Business Consultant
  8. Select the first checkmark (this is called Analytical Thinking)
  9. Click the PREV button (this is where it hangs)

If anyone could help I'd be very very happy... been trying to figure it out for a day...

Thanks

Stanton

18 Replies
stanton mackellar

Hi Christie, thanks for that note.

In the testing phase prior to being loaded on the LMS, courses for this client are shared with stakeholders for their input via internal SharePoint. There are strict limitations put on access to cloud based services.

I typically only Publish for LMS, and other than the non-functioning Exit button, I had never noticed any issue with this method before.

Reading your guidelines, I am inferring that publishing to CD would be your recommendation.

I'll give that a shot and see what is looks like.

Thanks again.

Stanton

 

stanton mackellar

Hi Leslie, I am getting back to this now as I was unable to resolve it earlier.

With acknowledgement to Christie's note related to testing environments, I tried downloading the version I uploaded above, which I in turn uploaded to tempshare later at home (I am restricted from cloud services from my work).

I encountered the exact issue I was complaining of. I do see your screen snap above showing that you were able to get it to work. Which is completely confusing. I cannot successfully test this in any way: with a preview, local LMS/Web/CD publish, or tempshare.

If you were able to get it to work, is there any way you could share a link of it published so that I can see if you are trying it the same way as me?

Many thanks

Stanton

Leslie McKerchie

Yeah, I think my head is spinning. I've deleted and moved and previewed so many times?!

I tried to find an e-mail for you so that I could at least send this to the support team on your behalf...but I see a couple and I'd hate to mix that up.

So, if you could shoot this file over to our team here, that would be great. Please let me know as I've invested enough time that I want to follow along :)