Navigation Not Working?

My player navigation is not working in one of my presentations. I did not alter the triggers that Storyline 2 entered automatically for me (except on one slide to see if it made a difference - it did not.). This is a project that I started in SL1 and upgraded to SL2. I did this successfully with another project that does not have this issue. Any ideas? Am I missing something obvious?

12 Replies
Victoria Nap

I'm working localy, and I have the navigation set to restricted, but that shouldn't matter. I always use that setting, and I'm still able to click next to move on, I just can't skip over slides using the menu. I've attached a sanitized version of my file for review. I could easily be missing something very obvious, but I just can't solve it.

Emily Ruby

Hello Victoria,

If you have the navigation set to Restricted in the Menu settings, The cannot use the Menu to navigate through slides.

Here are the options:

  • Free: This lets learners click slide titles in the menu to navigate to any part of the course at any time. They can view slides in any order.
  • Restricted: This means learners can view the current slide and any slide they previously viewed, but they can't use the menu to jump ahead or skip over slides.
  • Locked: This means learners can only view slides in the order you've designed. They can't use the menu to jump ahead or skip over slides, nor can they use it to go back to any previously viewed slides.

I changed the navigation in your file to Free and the navigation through the menu tab worked.

Let us know if you need anything else.

Victoria Nap

I'm sorry, I wasn't clear. I'm not trying to navigate using the menu. I'm trying to navigate using the Next and Previous buttons. They don't work. I've just now built another project where I can page back and forth through a scene, but can't get the next button to move me to the next scene, even though I've changed the triggers accordingly.

Emily Ruby

Hello Victoria,

Do you have a copy of the new file we can look at?  The previous file you attached was working properly with the next buttons. The content on the slide must complete in its entirety before the next button can be clicked when you have a restricted navigation.

Some of the slides had longer timelines, so the next button would not work until the timeline ended, such as the Inviting Colleagues slide which had 138 seconds)

i would be happy to look at the new file for you.

Cory Warshawsky

We've run into this similar issue when opening (and "converting") Storyline 1 files - to Storyline 2. In preivew or publish, we are unable to use the "Next Button" to progress in either a preivew or published version of the file. This seems to only affect the built in "next" button.

 Our solution/workaround: Head to the player options and "show" the menu. Then under the player properties tab, select "Menu". Click on the "cog" towars the bottom middle, and change "Navigation Restriction" to "free". Then return to the player options and "hide" the menu again.

In each instance that we've run into, this provided a quick solution.

Leslie McKerchie

Hi Cory!

Thanks for popping in to share your findings and solution.

It sounds like you are running into the following:

In Articulate Storyline 1, restricted and locked navigation settings only affected the menu. In contrast, the navigation settings in Articulate Storyline 2 affect both the menu and the player buttons, making it much easier to control the overall navigation for your course. To learn how to restrict or lock navigation in Storyline 2, see this article.
Jonathan McKee

I cannot get the navigation in Storyline 2 to work on the material I've imported from powerpoint. This is highly frustrating. 

I open storyline 2, set the design size, import the slides, and alter in the player to resize. Preview to test the resizing, the navigation doesn't work; try various settings in the player, and in the slide editor; I want navigation to be free, but I can't get any navigation at all.

Christie Pollick

Hi, Jonathan -- Thanks for reaching out and I attempted to import your file into a new file to see if that would be helpful, and when testing on tempshare.articulate.com, I encountered the same behavior you've described, so I would like our Support Engineers to take a closer look. I will create a case for you and you will be hearing from a member of that team as soon as possible. Your patience is appreciated! :)

Christie Pollick

UPDATE for anyone who was following along with Jonathan's case... Our Support Engineer, Eloisa, shared the following on 3/29/16:

"I am only able to reproduce this using your Powerpoint files. Navigation only worked when I imported the PPTX into a new Powerpoint file (do not keep source formatting) then import into Storyline2. Here are the steps: 

1. Open a new, blank presentation in PowerPoint. 
2. Go to the Design tab, click on Slide Size button, and set the slide size to be the same as the original project. 
3. Go to the Home tab, click the drop-down arrow beside New Slide, and choose Reuse Slides. 
4. In the Reuse Slides panel, click the Browse button and choose Browse File. 
5. Browse to your original PowerPoint file and click Open. 
6. At the bottom of the Reuse Slides panel, DO NOT MARK the box to Keep source formatting. 
7. Right-click the first slide in the Reuse Slides panel and select Insert All Slides. 
8. Save the new presentation 
9. Import into Storyline 2 

Please also see this info on Importing Slides from Microsoft PowerPoint."

Hope that helps! :)