Navigation problems with freeform Pick One and Pick Many

Hi there Storyline Gurus,

I have an issue when using freeform Pick One or Pick Many quiz slides, with no feedback and no score.  When I duplicate the slide, it creates a connection to the next slide in the number sequence.  I am creating a large branching scenario and the choice/button the user selects takes them to the slide relevant to their choice.  The phantom connections to the next slide in the number sequence are created in addition to my navigation, but are not editable (they don't highlight in storyview and just have the name of the scene).  I have ensured all next slide features are deleted, but still the link appears.   It does not happen if in freeform feedback is "by question" and score is "by question".  Is this a bug in my version of SL do you think?  Or is this expected behaviour and I shouldn't worry about the phantom connections? As I am working on a large, complex branching project, I don't want the unwanted links to create problems for me down the track. See attached example showing the link created.  Would love to hear from anyone.  Thanks Frances

6 Replies
Ashley Terwilliger

Hi Frances,

Thanks for sharing your file here - I didn't see the feedback branching you mentioned using, nor did those question in the scene have answers to choose from either.

The story view will show how slides are linked together and the numbering is for the purpose of an author alone (not something that your users will see). When you set up the feedback branching, you should see that appear in Story view as well based on how the user is set to navigate the course. You can read more about story view here. 

I don't think based on what you're describing and showing that you'll run into issues as you continue to develop - but please feel free to keep us posted. 

Frances Jones

Hi Ashley and thank you so much for the speedy response.   The example I attached was to show an example, (rather than my project) where the link to the next slide appears when using freeform Pick One or Pick Many when you have selected not to have any feedback and no score. Whereas, if you use freeform pick one and choose to have feedback or a score, then the duplicate slide just sits alongside the other, with no link to the next slide in the number.   You are correct that in the project I am working on I am dictating the branching, dependent on the choice the user selects. Each slide has 2 to 5 choices, with relevant branching off.

Thanks for the reassurance.  It sounds like I don't need to be worried about the link to the next slide in the number sequence.  Fingers crossed!  

Ashley Terwilliger

Hi Frances, 

Story view is something that regularly seems to confound users here in the forums, and even us as staff! You should be fine though with the step up if its working as you would expect and it's also worth looking to make sure you're following along with the other general guidelines to help prevent odd behavior. 

Frances Jones
Ashley Terwilliger

Hi Frances, 

Story view is something that regularly seems to confound users here in the forums, and even us as staff! You should be fine though with the step up if its working as you would expect and it's also worth looking to make sure you're following along with the other general guidelines to help prevent odd behavior. 

Hi Ashley, my project is progressing and it works well during play.  However, the numerical sequence in storyview is creating two issues for me, as I want to show the user feedback using the "Review Quiz" option from the results slide.  This is because we don't want to feed them information/tips during the play.

Issue 1.

"Review Quiz" only shows the slides in the numerical sequence (as shown in storyview) and not in the order of the path that the user took.

Issue 2.

Because my branching is complex, the review sometimes does not show slides if they do not follow the numerical sequence from storyview.

For example if the path taken was (slide numbers) 1.27 - 1.107 - 1.108 - 1.56.

Then quiz review shows 1.27, misses 1.107, missues 1.108, and shows 1.56 (because it is using the numerical sequence in storyview).  I have sent details to Ryan for case #00818200, as I think this is also the reason why I am having the issue that the quiz timer is not stopping on the results slide.  

Any advice on how I could show the review information in the order that the user took, rather than based on the numerical order in storyview?  Would really appreciate any tips.  :-)