Need help with triggers

OK I have read the tutorial on using states instead of variables to adjust other button states and changed the logic in my slide BUT still having the same problem.

I have three images/buttons the user must click and view layers before resuming main timeline with "continue" button. In preview it works fine but when I publish and run, the main timeline continues after closing first layer. I am not sure what is triggering the timeline to continue?

Really frustrated help!

5 Replies
Mark Pinkston

Yes thank you Leslie and I tried Richard Hill's work around closing layer with settings rather than a button and I still get the same results when layer closes with settings, main time line resumes once the layer timeline completes and hides. I even tried setting base layer to pause in layer properties

I have used this technique before with no problems only since latest update have I experienced a problem. This is a big problem because I use this technique numerous times in my lesson and now i will have to completely redesign the lesson logic. I use to be able to use variables as well but I get the same results with that approach.

Honestly issues like this are making me think we need a new authoring tool. I hope your staff can find a solution to this critical bug soon.

Ashley Terwilliger

Hi Mark,

I'm sorry that this issue is slowing you down.

As Leslie shared, it has been reported it to our team, and we continue to keep an eye on it to evaluate how many customers are impacted and what impact it has on courses. The number of customers and depth of impact are two of the elements that help us prioritize bugs and fixes. 

I'm really sorry that I can't say if this issue will be fixed but you're in the right place to stay updated on this bug's progress.