Need your help to solve the revisit issue.

Hi All,

    I need your help to fix one problem where I am getting issue.
    I have developed one course where I have used progress button as a slide like progress button 1=> slide1, progress button 2=> slide2 .. progress button N=> slideN.

 Here I have developed customized exercise for true & false with number of questions & validation slide means in slide there are 4 images & user can click on images randomly not in sequence.

  I have developed as explained above but I am getting issue while revisit above two slides.

  Exercise slide:- When I revisit the slide that time it don't ask for try again with 2 try which work fine while play fresh course/first time.

 Validation slide:- When revisit the slide that time if I click on 1st image then status of all other 3 images are also changes which works fine while play this slide first time or fresh course.

 I hope you will be give me solution for revisit. I am awaiting of your answer.

Cheers
Ashish

13 Replies
Brian Allen

Hello Ashish,

Not sure exactly what you're trying to do, but check out this page and scroll down until you see the "When revisiting" section, and see if the settings there help you with your revisit problem - http://community.articulate.com/tutorials/products/controlling-a-slide-s-advance-behavior-and-other-slide-properties.aspx

Martin Dean

Brian

Perhaps you can help me too?
I have a Web Video which plays in a slide layer when a button is clicked
The video plays fine on the first attempt
On revisiting the screen, the button to trigger the slide layer containing the video(iFrame) does nothing

If I refresh the package, the first attempt works again.

Any ideas?

 

Martin Dean

Hi Brian... Yes you are right, my name is often spotted... usually in the States, where I count to see how long after I arrive before someone mentions it! I respond that there are several things that differentiate me from Dean Martin; 1 - I can't sing, 2 - I have no money and 3 - I am still alive!

Will upload that .story file shortly

M

Martin Dean

@Ashley

Yes - as you probably gathered, I am on a full-on evaluation mission to move my company to SL2..

Attached is a test project that I wanted to use to view iFrame embeds in SL.  The navigation (which may be poorly implemented) takes the user to slide 2.1 and the iFrame is in a slide layer above that.

I have played around with it again briefly this morning and changed the 'revisit' properties to 'Reset to initial state' and that appears work on my PC but not on my iPad.  Although I think I have another issue in that the iPad may be 'caching' content in some way.   I need to make a visual change to the latest version so I can be sure iPad is looking at the right content.

Will look at this later today - have to go and earn some money this morning.

Ashley Terwilliger-Pollard

Hi Martin,

Thanks for sharing the file here. I took a look at it, and on slide 2.1 I didn't see any layers? Everything worked for me as expected when I published and test from Tempshare on my iPad mini with iOS8 in the mobile player and the HTML5 content. 

If I'm missing something let me know. 

Ashley Terwilliger-Pollard

Thanks Martin. That one I see the video now. :-)

I published again to Tempshare, and when viewing the HTML5 output, everything works normally.  (It takes a second to load the video, and you have to click to play as expected in HTML5). 

Within the mobile player, testing the same version on Tempshare, I can access the slide layer, but I'm seeing an "access denied" error in reference to the video in the frame, although I can see the frame (just a slight pixel on the far left side of white). It looks like the error is coming from the site hosting the video, not the course or the mobile player. Could there be restrictions from the site in terms of displaying content in an app, or security restrictions that would show that error? You may want to test a video from another site and set it up as you've configured this one to see how it appears within the mobile player. 

Martin Dean

@Ashley and @Brian

I owe you an apology - having got my files mixed up, I decided to make a new test file and set the slide layer 'revisit' properties and the iFrame works fine on both PC and tablet.

So I think I have solved my problem and many thanks to you both for your help.

http://strclients.com/Storyline_testing/MjD/test6_iframe4/story.html

The above link is to the resulting test.