New Button State Error

Is anyone else having this problem?  I set up a drag and drop question and got quite excited because I worked out how to make the "drop target" change colour if the drop was correct or incorrect.

However, each time I go to Edit States and add a new state for each drop target I get an error "We're sorry, something went wrong with Storyline and it might close".  It's really infuriating as I have six "drop targets" to edit..  Has this happened to anyone else and what is causing it?

Thanks in advance.

3 Replies
Christine Hendrickson

Hi Tex,

I can't really see why modifying any states would cause that type of error. Sounds like there may be a problem with the file, or the installation of Storyline.

First, please make sure you're working with local project files. 

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names (this includes spaces and underscores).

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

If you are working locally, can you try something, please? Create a new, blank Storyline course. Try to create a similar interaction (you won't need to worry about duplicating the content, just create the states) and see if the same thing happens.

If you don't see the same error in the new file, it may be an issue with the original course. If that's the case, are you able to share the .STORY file here? I'd be happy to take a look and see if I experience the same problem.

If you do see the same error in the new file, please try to perform a quick repair on Storyline:

Articulate Support > How to repair Storyline

Thanks Tex!

Christine

Tex Hale

Hi Christine

I'm working on my local drive.  I think the problem occurred because I was updating a previous drag and drop slide.  I inserted a new slide and duplicated the buttons, then added new states with no errors.  Sometimes it's so simple.  My fault for taking short cuts!!  

Many thanks.