New problem with recalling text variables

Hello everyone, 

I'm back into some variable problems again...seems like the issue that just keeps giving!

This time, I was having an issue previewing both a scene and the full course. I would immediately get a dialogue that Storyline encountered a problem and might close (see attached). Interestingly, if I previewed a single slide, there was no problem. After a few hours of dismantling the project, I discovered that it was the "%username%" variable recall I'd been using.  I've worked with this type of text recall before, so I'm surprised to encounter this problem.  

Additionally, I'm unable to style the font in the text entry box that sets the variable. The default text can be styled, but as soon as I click and begin to type, it changes to a completely different font.

Is this a new issue thats come along with an update? Are there known issues involved here? Are there any workarounds available? 


3 Replies
Sarah MacDonald

I discovered the answer on my own. It was the font I was using to recall the username. 

For future reference, if anyone is using the google font Roboto, the Roboto Black version WILL NOT WORK and will prevent you from being able to preview your project and give you error messages. However, if you use Roboto Bold, it WILL work. 

Another strange storyline bug! Who knows why it wont work. 

Ashley Terwilliger

Hi Sarah,

This is something we shared with our team as a possible software bug. 

From here, I’ll meet with my team to take a closer look so we can determine next steps. Sometimes my team catches errors in my logic and we don’t have a bug after all. Of course, if that’s the case, I’ll let you know! 

Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. Here's more information on how we identify and tackle bugs.

I’ll let you know as soon as we have an update on this issue. Thanks so much again for letting us know about this, and I’m sorry if it’s slowing you down.