No Audio on IOS Devices

My SCORM 1.2 packages produced in Storyline 2 to launch in the same window, and set to display on current window within Moodle are playing fine on a desktop computer, but the audio is not playing on iOS mobile devices.

After the user taps on the pause button and again on the play button, the audio is active and remains active for any subsequent modules within the course; I must mention this workaround has not always fixed the audio problem (I tried it once with my iPhone and it worked, and I tried it again, and it didn't).

 

18 Replies
Raquel Hernandez

Thanks for directing me to that article. I want to specify that our courses do not have any videos embedded or imported into any of the slides.  The article seems to refer to videos in the slides (it says: when they launch or resume a course with a video on the first slide). Also, I'm running the latest version of Storyline 2 (Update 13; Build 2.13.1804.2716), and the courses I'm testing were published with this version.   

Does this article apply to courses comprised of slides and audio (without video) published for LMS to include HTML5 output?

My publishing settings:

Include HTML5 output - Checked

Use Articulate Mobile Player for iOS or Android - Unchecked

  

Ashley Terwilliger

Hi Raquel,

Thanks for letting me know you're also using Storyline 2 as that narrows it down a bit! I know there our team saw similar issues where audio not playing automatically in HTML5 - and it sounds like that's what you're running into. Do you know what iOS you're using? Also, are you viewing the courses in Safari on your iOS devices? Have you compared that with HTML5 on a desktop browser such as Chrome? 

Ashley Terwilliger

Hi Raquel,

Are you able to share a copy of your .story files? I tested a quick sample and added audio to two slides. The first slide has the audio starting at the start of the timeline and the second slide has the same audio starting at about 1 second into the timeline. Both of those played the audio automatically on Safari on my iPhone 6S running 11.4.1. 

Can you test out this version uploaded to SCORM Cloud and this one on Amazon S3 and let me know how it works on your devices? 

Raquel Hernandez

Thanks for creating this test Ashley.  We were able to hear audio on Amazon S3, but not on SCORM Cloud. Same devices mentioned before were used for testing. On SCORM Cloud, we were able to hear the audio after we refreshed the page and launched the course again. 

Attached is one of my Story files. 

Alyssa Gomez

Hello, Raquel! Thanks for allowing us to test your file. I published it for LMS and hosted it on SCORM Cloud.

I then tested the SCORM Cloud link on an iPhone 6S (iOS 12.0) using Safari. I was able to hear the audio without any issues. 

Can you test this SCORM Cloud link on your device and let me know if you can also hear the audio?

Alyssa Gomez

Thanks for confirming that, Raquel! Let me gather what we've found so far:

  • We are both testing on an iPhone with iOS 12 and Safari.
  • We are both using Storyline 2 Update 13.
  • In your own SCORM Cloud testing, you could not hear audio the first time the content played. You had to refresh the page and relaunch the content.
  • When you tested my SCORM Cloud link, you were able to hear the audio the first time the content was played.

Does all of that look correct?

Raquel Hernandez

1 - The two iPhones we are using are running on iOS 10.3.2 (mine) and 12 (my manager's).

2 - Yes, we are using Storyline 2 Update 13.

3 - The quick sample Ashley uploaded to SCORM Cloud and Amazon S3 worked fine (we could hear sound) from the first time when we played the Amazon S3 version on both of our phones (my manager's and mine), but it didn't work for us (we couldn't hear sound) when we played the SCORM Cloud version, we had to refresh the page and relaunch.

4 - When I tested my PGP Ultra file you uploaded to SCORM Cloud, we both (my manager and I) were able to hear audio on our devices from the first time the content was played.  

Raquel Hernandez

I republished my PGP Ultra file and uploaded it to both my LMS (Moodle) and to SCORM Cloud.  At first, when I played the package uploaded to Moodle, the sound didn't play on my phone (iOS 10.3.2). I then played the version uploaded to SCORM Cloud, and it didn't play the sound either on my phone (not even after touching the pause and play button).  I asked my manager to play this SCORM Cloud package and it played perfectly on his.   

This morning, I revisited the Moodle package from my phone and it played fine.  I then logged on with a new account to test it, and although it didn't play the sound at first, when I clicked on the pause button, it started playing fine from there on.   

Ashley Terwilliger

Hi Raquel, 

Have you also confirmed that you and your colleague both had the mute toggle off? I know that sounds silly, but I've seen it impact enough people that I wanted to point it out! Another option would be to see if it plays through a headset on your iPhone. 

I'd also suggest closing out any previous versions of the courses, clearing the browser cache/history or launching in a private browser to ensure you're testing the latest version of the course. If you'd republished and overwrote what was previously there, it may be trying to load that older version. 

Lauren Connelly

Hi Annalisa!

Since this thread is a bit old, Raquel might not still be subscribed. I'd recommend contacting her directly using the Contact Me button in her ELH profile.

In the meantime, I'm happy to offer an update! We've found this issue only happens in Storyline 2 on iOS devices. Are you using Storyline 2 as well? Our team is looking into this Storyline 2 software bug, and I'll come back to this discussion when I hear of an update. 

If you're using another version of Storyline and still noticing this issue, please let me know!

Mike Mills

Hi Lauren,

I thought I had the same issue.  I am running the current version of SL 3, Update 8: 3.8.20838.0

My content has a video embedded and a slide with audio narration.  The video hosted elsewhere played fine with audio but my narrated slides did not have audio.  When I toggled the mute switch on the side of my iPhone, I had narrated audio as well.

Thanks for that tip above. :)

Happy New Year!