No search result after publishing

Hi,

 I have an SL3 project in HTML5 with the Search feature in the Menu. All was perfect and the Search result worked fine.

 However, for mysterious reason, the Search result is now always empty in the Publish version. In the preview mode the Search works.

 Between both situations I have added a Bank questions then I have deleted it and some unused scene and slides.

Is there any way to investigate or solution ?

Note that for confidential reason I cannot attach the project.

 Thanks

6 Replies
Ren Gomez

Hi Ricky,

Thanks for reaching out, and I'm sorry to hear you're running into this issue! I have a few questions to dig deeper, as you may be running into a bug we have reported where the search feature isn't functioning as expected.

  • What version of Storyline 3 are you on? You can view this by going to the Help tab, and clicking About Storyline.
  • Is the search function not working at all, or only for a few keywords?

I appreciate you working with us to confirm if this bug is what you're running into!

Ren Gomez

Hi Ricky,

Thanks for the clarification! Our support engineers would be happy to sign an NDA if you were up for sharing your file to take a closer look.

If that's not possible, one suggestion would be to importing your slides into a blank project file and see if the search tool still doesn't function as expected. It's possible that there may be some corruption issues specific to that file.

Give it a try and see if it helps!

Ricky Nox

Hello Ren,

Thanks for this idea. So I imported all slides in a new project and no change.

I've seen that some old quiz variables, like scoreresult...  already exist in my project whereas I have deleted the quiz. But I cannot delete these variables. Could it be a clue for this issue ?

Anyway how works the Search ? Is it a live search or is there an index file somewhere ?

San