No Shadow Effect on button with picture fill...

Hello All,

Another entry in the ongoing (and slightly facinating) web series I like to call "Articulate: Is it Just Me?"  or "How to stop being InArticulate"  (ooh, bad pun).

I noticed that when I crete a button (using the stock buttons from Storyline) and I use the picture fill effect, I am unable to apply a shadow to the button.  I go through the motions and I apply the shadow effect and even try to fool around with the finer options by right-clicking the button and using the Format Shape menu.

Is it just me?

12 Replies
Heather Steckley

Interesting... I think this might be a bug.  I tweaked the shadow on a picture-filled button as best I could to duplicate the default shadow on the default button.  It's still really too light to match, but I'm including the properties in case you want to use them.  It's using black with zero transparency, so I can't figure a way to darken it.

Christine Hendrickson

Hi all!

First, thanks for bringing this to our attention, Pedro :)

It looks like there is a shadow that's applied - but it's very difficult to see. When I apply a shadow, it's similar to what Heather showed in her screenshot, but I've made no alterations.

Here's the differences that I see:

I applied the same shadowing to both the shapes (on the right) and the buttons (on the left).

As you can see, both objects appear to lighten the shadow - but there is still shadow present. 

I'm not sure if this is intended for objects with an image fill (not sure why it would be) or whether this is a bug. 

I'm going to pass the information you all shared with our QA team, as well as the files where I was able to reproduce this. 

If you find any additional information or workarounds, please share!

Thanks very much :)

Pedro Fernandez

Christine,

Thanks for looking in to this!

An now another exciting chapter in the ongoing web series "Articulate: Is it just me?" or "How to draw a straight Storyline".

I also found some more bizarre (well, maybe just weird but I like to use bizarre in a sentance at least three times a day.) 

  1. Create a new Freeform Multiple Choice quiz slide
  2. Insert a question and four buttons (again using pre-built buttons from Storyline), with text
  3. Use the Fill with Picture effect.
  4. Set up the answer and the distractors using the Edit Pick One panel.
  5. Make sure to set the answers to shuffle.  Save your edits.
  6. Preview the Multiple Choice quiz question.
  7. Stand back and watch as the picture that is supposed to show up on/in your buttons does not appear.  But wait!  They magically appear as you wave your mouse over each button!

So, every time I try to fill a stock Storyline button with a picture, in a quiz, and I use Shuffle the buttons behave this way.  No Shuffle, No problem.  But that kind of defeats the purpose of what I am trying to accomplish, no?

Tried different pictures, different sizes, etc.  Seems to always happen when I use a picture fill instead of a color fill and always when I use the "shuffle option".

--As Charlie Brown said to Lucy: "aaaaarrrrrggggh!!!"

Pedro Fernandez

Christine,

The more I "kick the tires" in Storyline, the more "interesting behaviors" I find I find with the stock buttons in Storyline.

I started to use the stock buttons because I found that I could work much faster if I put the stock buttons in a custom quiz and then filled each button in with a picture.  This made the various types of questions a bit more engaging than the standard text-only quizzes I was provided.  (you know built in states are better than customized buttons any day, especially when doing a rapid dev project).

I have made several posts in this forum about the stock buttons before and so I wonder if providing a laundry list of issues would be helpful.

For example: Did you know that if you make a stock button with text invisible, the stock shadow effect is applied to the text?  A sane person would try to get rid of it by using the text Font panel from within the Home tab only to discover that the text shadows never go away!

Christine Hendrickson

@Jeff -

Well, don't I feel silly? :) Yes, actually - when I preview, they all look exactly the same to me. If anyone else could try this and confirm, I'd appreciate it.

@Pedro - 

My goodness! You have been busy :)

For your first "bizarre" find - you're referring to the free form "Pick One" - correct? I tried with this particular quiz type as well and was able to reproduce the same result. It's almost as if the "Normal" state doesn't kick in until the "Hover" state has been used. 

As a matter of fact, if you trigger the button to change to the "Hover" state when the timeline starts, it shows up properly when the slide loads. Until I get a little more information on this, you could certainly use that option as a workaround temporarily, especially if you aren't using any special effects for the "Hover" state. 

------

For the other issue on your laundry list;

Can you provide a little more information on how you applied the "invisible text"? Doesn't sound quite so invisible with that shadow ;)

I'd like to test this out as well, if you could walk me through the steps you've taken when you see this happening. 

If I could take a look and confirm this happens, I can pass along the information. Hopefully, I can find a solution for this, but if not, then we can get some additional investigation going on the issue.

Thanks!

Rebecca Fleisch Cordeiro

Christine Hendrickson said:

@Jeff -

Well, don't I feel silly? Yes, actually - when I preview, they all look exactly the same to me. If anyone else could try this and confirm, I'd appreciate it.

sheepishly....yes, I CAN see the shadow in preview. But that even more makes me think this is a bug. Why would we be able to see in Normal mode the shadow for buttons with "standard" fills but not for picture/text fills?
Pedro Fernandez

Christine,

I am sorry about the misunderstanding.

Issue 1:

  • I meant: add a Storyline button to a slide.  Any button will do as long as you create a button by picking one of the stock buttons from within Storyline.
  • Add text (double click the button then type a word like NEXT or something) to the button.
  • Make the button clear (remove the fill color).  Remove the border.
  • Take a look at the text.   You will notice a shadow on the text, nothing but the text and only the text.
  • You can go through each button State and try to remove the shadow from the text but it persists.
  • Then go to the button properties and remove the shadow from the button itself.  Now the text has no shadow!

Issue 2

  • Add a Storyline button to a slide.  Any button will do as long as you create a button by picking one of the stock buttons from within Storyline.
  • Add text (double click the button then type a word like NEXT or something) to the button.
  • Make the button clear (remove the fill color).  Remove the border.
  • Try to select the button by clicking on the boarder of the button.  I can't.
  • To select the button I have to click on the text, which drops me right in to editing the button text.  NOW I can click on the button edge and select the button!

I know that this strange but I can replicate this over and over on my system.  If I have some time this PM I will record what I see in my version of Storyline.

P.S. - I used to be a hardware/software tester so sometimes I get a bit focused on replicating odd behavior in software (not to mention that I am a bit odd myself.

Pedro Fernandez

Issue 3

  1. Start a new Story in Storyline
  2. Insert a new Free Form Quiz question of type "Pick One"
  3. Create a text box and enter some text on the single slide
  4. Create some buttons using the "Interactive Objects" tool from the Insert ribbon.
  5. Use the picture fill effect for each button (choose whatever you would like).
  6. Enter a text label for each button
  7. Use the Edit Pick One menu and set up your distractors and your answer.  Save your changes
  8. Use Preview -> This Slide.  Everything should work.
  9. Now go back and use the "Edit Pick One" button to enable shuffling of the answers (those pesky buttons with picture fill).  Save your changes.
  10. Use the Preview feature again.  Notice anything?  Yeah those buttons are not  there.  At least not until you mouse over them.

So, is it just me or is this "a thing" for others?

Christine Hendrickson

Hi Pedro!

I apologize for the delay - as I mentioned in the other thread, it's been a bit busy around here. 

I've taken a look at the 3 issues you provided and here's my feedback:

Issue #1:

I tested this out (in Slide 1 of the attached).

While I appreciate your additional solution, I think the shadow you're seeing is by design.

Having said that, however, there's a much easier way to remove the shadow.

Here's how:

  • Insert a Storyline stock button into your slide.
  • Apply text to the stock button, remove the fill and remove the border. 
  • Select the entire button, not the text and then remove the shadowing option under the "Home" tab for text formatting.

It should look like this:

Issue #2:

This is also by design - the lines that are now provided for the button are simply to let you know where the shape would end if it had an active border. Since you've removed the fill and the border there's no content there to select, besides the text. 

Correct, you can click on the text to select the button. Another option is to hit "Tab" to cycle through the objects on your slide. This cycles through the top most item in the timeline, down to the last. 

Another option would be to use a fill and border color, but make them 100% transparent - applied to slide 2 in attached as an example.

Issue #3:

As discussed earlier, I do agree that this is an issue.

"I tried with this particular quiz type as well and was able to reproduce the same result. It's almost as if the "Normal" state doesn't kick in until the "Hover" state has been used. 

As a matter of fact, if you trigger the button to change to the "Hover" state when the timeline starts, it shows up properly when the slide loads. Until I get a little more information on this, you could certainly use that option as a workaround temporarily, especially if you aren't using any special effects for the "Hover" state."

Thank you for clarifying the steps you took for this issue. I am able to reproduce this and I will be sharing this information with our QA team for some additional testing. In the meantime, try using the workaround I suggested.

Thanks again for your time and the information, Pedro! I appreciate it :)