Not tracking Tin Can in Scorm Cloud

I am testing my Storyline-created course via Scorm Cloud on the PC.

I can load and launch the course fine. However, after passing the quiz, the completion and satisfaction statuses in Scorm Cloud remain unknown, and the total time is 0s.

Does anyone know why this is happening?

I have:

- Installed Update 5 for Storyline

- Ticked the AMP on iPad box when publishing

- Selected Tin Can API as the output option

11 Replies
Ryan Tracey

Thanks for your reply, Ashley.

For this course I've only ever used Scorm 1.2 on the Saba Enterprise LMS, which is not Tin Can compatible.

I tested it on the AMP app too, and it didn't work via that either. The app was the latest version downloaded and installed yesterday. (Actually, it was because the AMP app wasn't tracking that I tried the PC and found out it didn't work there either.)

I've tried using IE9 and FF26, both with no luck.

I've also tried someone else's Tin Can compliant course created with Presenter (I think), which works fine. So this makes me wonder if it's a Storyline issue?

Ashley Terwilliger

Hi Ryan,

To use the Mobile player you would need to publish for Tin Can and have a Tin Can compatible LMS as described here. 

There is a known issue with Scorm 1.2 and Saba where the course is never set to complete and a method to fix it described here. Additionally, you'll also want to look at how you've set up the tracking/reporting within the Storyline course itself. Are you tracking by a quiz or by number of slides viewed? 

I'd also recommend reviewing this article on troubleshooting common LMS reporting and tracking issues. 

Ryan Tracey

Apologies for the misunderstanding, Ashley. I'm trying to make my course work on the PC (not the mobile player) and my Scorm 1.2 version works fine.

I've read the LMS troubleshotting article but unfortunately it didn't help.

HOWEVER, I tried switching the tracking from the quiz to the number of slides viewed, and the latter worked! So this narrows it down to how the quiz is being handled... are you aware of any specific issues?

Ashley Terwilliger

Hi Ryan,

I'd want to take a look at your course and do some additional testing on why the quiz slides wouldn't be tracking in SCORM 1.2. Did you review the previous support article here on SCORM 1.2 with Saba?

If you're able to share the Storyline file here I can take a look and if you'd prefer to share privately please let me know and I'll send directions along to share with me privately. 

David Sensenig

Ashley, the link "Tin Can API Content Isn't Tracked When Viewed in the Articulate Mobile Player" says that you can check what version of the AMP you are using by clicking the "Help" icon. My version of the AMP does not have a help icon, just Library and Favorites. I just downloaded it within the last 4-6 weeks. When I visit the app store, it prompts me to open the app but not to upgrade. Any ideas what version I'm using/why my interface looks different?

Nancy Woinoski

I wonder if it has anything to do with the version of tin can Storyline is using. Scorm Cloud is uses version 1.0 and Storyline uses an earlier version of tin can.  Presenter works for you because it is using tin can version 1.0.

In another post I remember Phil Mayor saying something about a converter that you can use to fix the problem- sorry can't remember the details.

Ashley Terwilliger

HI David,

Good catch - I don't know that the article was updated for the most recent version of the Mobile player. You can also check it by going to the Settings for your iPad and then: 

  1. From the left navigation pane, tap General.
  2. In the details pane on the right, tap Usage.
  3. Under Storage, tap the Articulate app. If you don't see it in the list, tap Show all Apps.
  4. You'll see the version number just below the app name.

Ryan Tracey

Thanks for your help Ashley, but my problem related to Tin Can, not to Scorm 1.2.

I've since figured out the root cause of the problem was that the course has multiple quizzes in it, and Storyline tracks the results of only 1 quiz. Tracy Parish has shared a work-around that I'm keen to try out: http://www.tracyparish.ca/2013/02/creating-and-tracking-a-storyline-course-with-multiple-quizzes.html

Why it works in Scorm 1.2 but not in Tin Can is still a mystery to me, but nonetheless I hope my experience helps others who strike a similar issue.