SuccessFactors LMS & Storyline

Hi,

I assume this may be a quick fix for someone experienced with SuccessFactors and Storyline.

I published a Storyline course using Scorm 1.2, and my client can't seem to get it to work in their SuccessFactors LMS.

Here is what she wrote, “When I am asked to select a launch method I chose scorm1.2 (other options are content player, browser, aicc…). Is there any other specific setting I need to pay attention to? The error message is ‘no launch file specified’.”

I'm not familiar with SuccessFactors, and can't find a video on YouTube showing what to look at, which is strange.

BTW. I tested in Scorm Cloud and the course work perfectly. So, I assume it's a SuccessFactors setting.

Thanks for any help.

Ryan

10 Replies
Michelle Fisher

We have had SuccessFactors LMS for about 6 years and have published to SCORM1.2 and 2004 and did not have issues previously. Something must have changed this year, because the same Storyline files with a few minor edits and published to SCORM2004 will now not load to SuccessFactors and reports an issue with the manifest file. Please post if you figure out the issue and I will update as well, if we can figure out a solution. 

Michelle Fisher

Not sure if this will be helpful, but the error message the LMS is giving us when trying to upload SCORM 2004 (2nd Edition) content:

The parser could not validate the SCORM Import file due to the following reason(s). Proceeding with the import may incompletely import the file, or the file itself may be corrupt. You may choose to continue with the import at your own risk.

Error on line 2: cvc-elt.1: Cannot find the declaration of element 'manifest'.

Uploading the content to SCORMCloud, does not report any issues with the files. 

Ashley Terwilliger

Hi Michelle,

I'm so sorry you're still struggling with this. Have you reached out to your LMS admin to see if there is anything specific you need to change within Storyline or SuccessFactors to get this working right? 

I don't know enough about SuccessFactors to share more than that, but if it's successfully uploading and playing at SCORM Cloud that's a great sign that the file is packaged correctly and everything working as it should there.

Michelle Fisher

Unfortunately I am the LMS Admin :) We have sent the issues over to our LMS vendor for troubleshooting, but the only help they have provided so far is informed us that there is an issue with the content. According to their documentation from what I can tell it meets their requirements and SCORMCloud does not find any issues with the content or manifest. The vendor is not the easiest to work with so I was posting on here hoping others may have found a solution for this LMS. 

Ashley Terwilliger

😕 Sorry, I can't be of more help, Michelle!

If the LMS vendor can offer any more details or specifics about what they believe the issue is, that would help myself or others in the Community share more ideas. 

What happens when you "choose to continue with the import"? Does it load the course for playback or crash SuccessFactors, or something else? 

Erin Janes

We are coming across this same issue in SuccessFactors.  I need to be able to report out on a particular quiz in my content so the LMS vendor advised that I publish to SCORM 2004 to enable that type of reporting but I get this same error when uploading the file.  SCORM 1.2 uploads fine but I can't get the detail I want.  Mine would not play even if I ignored the error and continued with the upload.  Curious if it worked for you if you published Pass/Fail or Pass/Incomplete?

Herminder Singh

My two cents on this issue.

The following error got resolved by updating 'imsmanifest.xml'

Error on line 2: cvc-elt.1: Cannot find the declaration of element 'manifest'.

<manifest identifier="course_identifier_id(replace with unique id of the course)" version="1.3"
xmlns="http://www.imsglobal.org/xsd/imscp_v1p1"
xmlns:adlcp="http://www.adlnet.org/xsd/adlcp_v1p3"
xmlns:adlseq="http://www.adlnet.org/xsd/adlseq_v1p3"
xmlns:adlnav="http://www.adlnet.org/xsd/adlnav_v1p3"
xmlns:imsss="http://www.imsglobal.org/xsd/imsss"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:lom="http://ltsc.ieee.org/xsd/LOM"
xsi:schemaLocation="http://www.imsglobal.org/xsd/imscp_v1p1 imscp_v1p1.xsd
http://www.adlnet.org/xsd/adlcp_v1p3 adlcp_v1p3.xsd
http://www.adlnet.org/xsd/adlseq_v1p3 adlseq_v1p3.xsd
http://www.adlnet.org/xsd/adlnav_v1p3 adlnav_v1p3.xsd
http://www.imsglobal.org/xsd/imsss imsss_v1p0.xsd
http://ltsc.ieee.org/xsd/LOM lom.xsd">

More information can be found at:

https://community.articulate.com/discussions/articulate-storyline/scorm-manifest-causing-issues-with-unix-based-server

You may also check for this in the following location on your machine:

C:\Program Files\Articulate\360\Storyline\Content