Parameter is not valid - unable to save story file

Hi,

I'm pulling together multiple storyline files into a single file and recieving the error "The project  file can not be saved.  Parameter is not valid".  It seems to only happen when I've added a specific storyline file and unfortunately I'm unable to share the actual story file.  

All the story files that I am importing into this one main file are just step by step view mode screencasts with some voice over added. I can't really think of anything that sets this one speciofic file apart from the rest to cause this error.

Anyone have experience with this error message?

5 Replies
Christine Hendrickson

Hi Noel,

First, please make sure that you're working with a local project file when you modify or publish your project. If you're working on a network drive, or any other external storage, that might be causing the trouble. 

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names (this includes spaces and underscores).

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

Please make sure you're running the most recent version of Storyline. Articulate Storyline Update 5 includes bug fixes, performance improvements, and HTML5 output enhancements. Click here for details.

If this only happens with a specific file, try importing the content from the file into a new, blank project. 

Also, please make sure you're using this method to import - try to avoid copying and pasting your slides if possible. 

If you're still having trouble, and you'd like to share the file with me privately, please let me know. I'd be happy to take a look.

Thanks!

Noel Coloma

Hi Christine,

Thanks so much for the quick response and suggestions.  The only item that I hadn't tried was the update and I just installed and rebooted and tried again and it's still showing that same answer.  I also just tried importing it into a new blank project and still the same result.

Due to the sensitive information within the screencast I wouldn't be able to send it for you to take a look.   The only other option I can think of would be re-create the entire screencast altogether and try again.

I really appreciate your help though Christine!

Christine Hendrickson

Hi Noel,

No problem at all!

I just wanted to reiterate that any content shared with us privately will remain confidential. If you decide you'd like me to take a look, I can send you the details for sharing the file with me. 

In the meantime, it may help to run a quick repair:

Articulate Support - How to Repair Articulate Storyline

If running the repair does not solve the problem, please try following the troubleshooting steps outlined in the following article:

Unexpected or Erratic Behavior in Articulate Storyline

Let me know if you see any improvement.

Thanks!

Noel Coloma

Hi Christine,

I tried recreating the entire scene and it still didn't work.  Then I tried to go back to the orginal storyfile that I assumed was the root cause and imported each individual scene into my main scene one by one.

Import file ->  Select scene

Rinse, repeat.

Luckily there were only 3 scenes but still very curious why this would make a difference as opposed to just importing the entire story file in one step.  I'm gonna chalk this one up to software demonic posession. 

Can I suggest a feature request called Storyline Exocisms?

Thanks again Christine

Christine Hendrickson

Hi Noel,

I'd love to see that feature request come in, actually :)

I agree that it's odd - it could have something to do with the content, or a piece of that content being corrupt, rather than the file. 

If you're ever interested in looking further into it, I'd be happy to test it and see what's going on. If you want to do this on your own, my usual process is to remove one item/object at a time and test. It can take some time, depending on the amount of content, but it usually narrows down the issue. Sometimes it's related to text, sometimes images or other media. Again, though, it's difficult to say from this end. 

Let me know if you run into this again, or if you'd like to continue working on this. 

Have a great day, Noel!