Picture Shape issue

Hi,

I have stumbled across something, that unless anyone can correct the error of my ways, I consider to be a bug.

We all know that with a picture you can right click, select Change Picture and change the picture. However, here is my problem. I have created a project with Thinkstock watermarked images in, that I am now at the point of replacing with the real paid-for downloaded images. The issue is that with my watermarked pictures in Storyline, I had selected Picture Shape and chosen a circle. I had also used Picture Border and added a border.

Now try doing right click and select Change Picture to that. Doesn't work. The new picture does not replace the old one. Problem is that I have a lot of these and they all have triggers on. So far all I can see is that you cannot change the picture if you ever chose Picture Shape and selected a picture shape originally for your picture.

Unless anyone can say otherwise, looks like a bug to me. Have recreated issue on another computer with a blank .story.

Anyone know what issue is?

Thanks.

7 Replies
Rebecca Fleisch Cordeiro

Hi Rupert,

I've been able to add a picture shape and a border, and Change Picture works for me...keeps the border and the circle shape. So, I don't know if this has to do with the watermarked, unpaid for version...or what the difference may be. Perhaps someone else can jump in and address this.

Ashley Terwilliger

Hi Rupert,

I'm not able to replicate this either - and am curious if you're able to change the images using something other than these watermarked images to test if it has to do with those images as mentioned? I also tried it with different image types - changing from a PNG to a JPEG, and it all worked as expected. 

You mentioned recreating the issue on another computer with a new story, were you using the same images? 

Andrea Cagli

Hi everyone. I know this thread is some time old, but I'm experiencing almost the same problem.

I can replace pictures when they are "normal pictures". The real issue is if the pictures are possible answers of a Pick one/Pick many freeform (haven't tested with DragDrop).

Let's say I want to create a Pick one freeform having a choice between two pictures. I insert the pictures, convert the slide to freeform, set the images as possible answers, set the correct one. In this scenario I do not apply the shape to the image, and if I do the "replace picture", it works and the interaction works fine with the new images.

But if I do give a shape to the image, and I try the replace image, it doesn't change the image on the slide. But, if I try to move the image, while I'm moving it, I can see the new one, but as soon as I release the mouse, I can see only the old one. And the interaction in the preview is shown with the old image

I've also tried all of this with states, following this procedure:
Inside a PickOne freeform slide, I insert the picture, I create a black and white state, I apply the shape the the interaction works fine. If I try to replace the image, the replacement is done only on the black and white state but not in the normal state.

Anyone else experienced the same issue?

Leslie McKerchie

Hi Andrea - Sorry to hear that you have run into a similar issue. Unfortunately, no files were shared here and as you can see above we were unable to replicate the issue. Do you have a .story file we could take a look at and let us know the images you are having difficulty with? That would help us better understand and see what may be going on.

Leslie McKerchie

Hello Andrea - I apologize for the delay. I must have missed the notification when you attached your project. I took a look today and I do see what you are reporting. I also see where a similar issue has previously been reported, so I will add your .story file and this thread to the report. This will help with the investigation, with tracking users reporting the issue, and allow us to update here when applicable.